Sync encountered an error while syncing: incorrect account name or password. Sync will automatically retry this action.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: ghepardoxyz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8348278 [details]
error-1387225993157.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 2013102400

Steps to reproduce:

I run the sync server locally on linux. 
I try to synchronize. 

At this link there is a better explanation:
https://mail.mozilla.org/pipermail/services-dev/2013-December/001844.html


Actual results:

I just get the error
"Sync encountered an error while syncing: incorrect account name or password, Sync will automatically retry this action."


Nothing happens.


Expected results:

Firefox should synchronize my bookmarks.
(Reporter)

Comment 1

5 years ago
Hello.
I am running the sync server locally on linux.
The server start without problem.
When I start the server, in the terminal (konsole) I get a message like:


############START##########
Starting server in PID 18750.
serving on 0.0.0.0:5000 view at http://127.0.0.1:5000
############END############






Firefox see the server at the address http://localhost:5000.
I can create an account (I think).

When I try to synchronize, the browser (firefox) says:
"Sync encountered an error while syncing: incorrect account name or password, Sync will automatically retry this action."





In the terminal I get a message like:

############START##########

2013-12-16 15:05:53,136 INFO  [syncserver] 127.0.0.1 - - [16/Dec/2013:15:05:53 +0200] "GET /user/1.0/4l4lyvt5el6a4b3ibrkneu25xuklovm2/node/weave HTTP/1.1" 200 32 "-" "Firefox/25.0 FxSync/1.27.0.2013102400.desktop"
127.0.0.1 - - [16/Dec/2013:15:05:53 +0200] "GET /user/1.0/4l4lyvt5el6a4b3ibrkneu25xuklovm2/node/weave HTTP/1.1" 200 32 "-" "Firefox/25.0 FxSync/1.27.0.2013102400.desktop"

############END############











My sync-error.log  (/tmp/sync-error.log) is empty.

The size of my sql databese (/temp/test.db) is 13.0K.

So, I think the database is basically empty.

I am on linux (kernel 3.7), firefox 25, suse 12.3.
My local sync server and my O.S. are up to date.

I tried with superuser and with simple user.




------------------------------------------------
MY FILES





1)This is my sync.conf



############START##########
[global]
clean_shutdown = false

[captcha]
use = false
public_key = 6Le8OLwSAAAAAK-wkjNPBtHD4Iv50moNFANIalJL
private_key = [here is my private key]
use_ssl = false

[storage]
backend = syncstorage.storage.sql.SQLStorage
sqluri = sqlite:////tmp/test.db
standard_collections = false
use_quota = true
quota_size = 5120
pool_size = 100
pool_recycle = 3600
reset_on_return = true
display_config = true
create_tables = true

[auth]
backend = services.user.sql.SQLUser
sqluri = sqlite:////tmp/test.db
pool_size = 100
pool_recycle = 3600
create_tables = true
# Uncomment the next line to disable creation of new user accounts.
allow_new_users = true

[nodes]
# You must set this to your client-visible server URL.
fallback_node = http://localhost:5000/

[smtp]
host = localhost
port = 25
sender = weave@mozilla.com

[cef]
use = true
file = syslog
vendor = mozilla
version = 0
device_version = 1.3
product = weave

[reset_codes]
backend = services.resetcodes.rc_sql.ResetCodeSQL
sqluri = sqlite:////tmp/test.db
create_tables = True


############END############









2)This is my development.ini


############START##########

[DEFAULT]
debug = True
translogger = False
profile = False

[server:main]
use = egg:Paste#http
host = 0.0.0.0
port = 5000
use_threadpool = True
threadpool_workers = 60

[app:main]
use = egg:SyncServer
configuration = file:%(here)s/etc/sync.conf

#
# logging
#
[loggers]
keys = root,syncserver

[handlers]
keys = global,syncserver,syncserver_errors

[formatters]
keys = generic

[logger_root]
level = WARNING
handlers = global

[logger_syncserver]
qualname = syncserver
level = ERROR
handlers = syncserver,syncserver_errors
propagate = 0

[logger_syncserver_errors]
qualname = syncserver
level = ERROR
handlers = syncserver_errors
propagate = 0


[handler_global]
class = StreamHandler
args = (sys.stderr,)
level = DEBUG
formatter = generic

[handler_syncserver]
class = StreamHandler
args = (sys.stderr,)
level = INFO
formatter = generic

[handler_syncserver_errors]
class = handlers.RotatingFileHandler
args = ('/tmp/sync-error.log',)
level = ERROR
formatter = generic

[formatter_generic]
format = %(asctime)s,%(msecs)03d %(levelname)-5.5s [%(name)s] %(message)s
datefmt = %Y-%m-%d %H:%M:%S



############END############















3)This is my sqlite.conf



############START##########
[captcha]
use = true
public_key = 6Le8OLwSAAAAAK-wkjNPBtHD4Iv50moNFANIalJL
private_key = [here is my private key]
use_ssl = false

[storage]
backend = syncstorage.storage.sql.SQLStorage
sqluri = sqlite:////tmp/test.db
standard_collections = false
use_quota = true
quota_size = 5120
pool_size = 100
pool_recycle = 3600
create_tables = true

[auth]
backend = services.user.sql.SQLUser
sqluri = sqlite:////tmp/test.db
pool_size = 100
pool_recycle = 3600
create_tables = true
# Uncomment the next line to disable creation of new user accounts.
#allow_new_users = false

[nodes]
# You must set this to your client-visible server URL.
fallback_node = http://localhost:5000

[smtp]
host = localhost
port = 25
sender = weave@mozilla.com

[cef]
use = true
file = syslog
vendor = mozilla
version = 0
device_version = 1.3
product = weave

############END############











4)I have a python script (get_data.py) to read row by row the sql database, when I run this script I get this message. (I don't know python or sql language).



############START##########
python get_data.py


(1, u'nl4oj3cagfkf42hdbvapiaenliyrvhh7', u'{SSCRYPT}HSihrGRUCI0oRAkukMz2r1g0QFo/EW0cbeWhWBInqidL+sOx4cqdd5TTyJQjRKYZ8ind3a4TG0B/kw+6CiY7ImRlQTdxcVM3', 1, u'myemail@gmail.com', 0, None)


############END############















5)The python script I use to get data is this


############START##########
#!/usr/bin/python
# -*- coding: utf-8 -*-
#get_data.py


import sqlite3 as lite
import sys


con = lite.connect('test.db')

with con:

    cur = con.cursor()
    cur.execute("SELECT * FROM user")

    rows = cur.fetchall()

    for row in rows:
        print row


############END############
(Reporter)

Comment 2

5 years ago
My mistake.
This is not a bug.
I haven't set the fallback_node (fallback_node = http://localhost:5000/).
Sorry
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.