Failed GET request on /search and /featured requests on Android

RESOLVED WORKSFORME

Status

Marketplace
Consumer Pages
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: krupa, Unassigned)

Tracking

({regression})

2013-12-17
All
Android
regression
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8348294 [details]
screenshot.JPG

Firefox Mobile Nightly/Samsung Android

steps to reproduce:
scenario 1:
1. Load marketplace-dev on Firefox mobile nightly
2. Search for "twitter"

scenario 2: Load marketplace-dev homepage on Firefox mobile nightly

expected behavior:
scenario 1: Search returns appropriate results

scenario 2: Homepage loads with featured content

observed behavior:
-- Search returns "no results found, try again later"
-- Homepage has no content

Same behavior is sometimes noticed on the hompeage where no apps load due to GET request failing on /featured

ashes:
-- for search
[req] GETing https://marketplace-dev.allizom.org/api/v1/apps/search/?_user=---&dev=android&device=mobile&lang=en-US&q=twitter&region=de
[tracking] Tracking page view /search?q=twitter
[nav] Setting scroll to
[nav] Pushed state onto stack: /search?q=twitter
[req] Request failed: GET 

-- for featured apps
[req] GETing https://marketplace-dev.allizom.org/api/v1/fireplace/search/featured/?_user=---&cat=&dev=android&device=mobile&lang=en-US&region=us
[req] Request failed: GET 

ashes ID for search:10afe
ashes ID for featured: 15671
(Reporter)

Comment 1

4 years ago
I can reproduce this behavior on inari 1.3 too
Summary: Failed GET request on /search and /featured requests on Android → Failed GET request on /search and /featured requests on Android/Firefox OS
(Reporter)

Comment 2

4 years ago
(In reply to krupa raj[:krupa] from comment #1)
> I can reproduce this behavior on inari 1.3 too

Please ignore. Requests are just slow on firefox os. They still return results.
Summary: Failed GET request on /search and /featured requests on Android/Firefox OS → Failed GET request on /search and /featured requests on Android
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.