Notes+ app shows large image without resizing to fit screen

VERIFIED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Yan Or, Assigned: Yan Or)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

43 bytes, text/x-github-pull-request
ranbena
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Images wider than the device screen will be clipped and hard to see.
Should resize image to fit screen width.
(Assignee)

Updated

4 years ago
Assignee: nobody → yor
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 8355993 [details] [review]
Pull request
Attachment #8355993 - Flags: review?(matias)
Comment on attachment 8355993 [details] [review]
Pull request

r+ from Matias
Attachment #8355993 - Flags: review?(matias) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
phase2: https://github.com/mozilla-b2g/notes/commit/eedcb3cbfc34def6f486a79e1547cd54674e395a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
I'm not sure if it's intended behavior but I'm seeing all images as attachments instead of being embedded as before.  Because they are now attachments they are no longer displayed within the body of a note.

App built using:
https://github.com/mozilla-b2g/notes/tree/phase2

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a43cb4b322d3
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Platform Version: 28.0a2
Firmware Version: 20131115
(Assignee)

Comment 5

4 years ago
That is not the intended behavior.  Can you provide step by step on how to reproduce this?
Also, is this reproducible on the simulator?
Using steps found in bug 956950 to build the app I am able to verify that large images no longer clip the screen and are re sized after a cropping step to fit the view.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a43cb4b322d3
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Platform Version: 28.0a2
Firmware Version: 20131115
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.