Closed Bug 950989 Opened 7 years ago Closed 7 years ago

[B2G][Gallery] Pressing thumbnail in Camera app while tapping screen to dismiss thumbnail overlay results in area of transparency

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox29 affected, b2g-v1.2 affected, b2g-v1.3 affected)

RESOLVED DUPLICATE of bug 934366
Tracking Status
firefox29 --- affected
b2g-v1.2 --- affected
b2g-v1.3 --- affected

People

(Reporter: bzumwalt, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot
Description:
Tapping the thumbnail of a recently taken photo in the camera app while pressing the center of the screen to dismiss thumbnail overlay causes picture preview to appear with transparent bar at top of screen. User can see current camera view through this transparent area.

Repro Steps:
1) Updated Buri to Build ID: 20131216040201
2) Open Camera app
3) Tap camera icon to take picture
4) Select thumbnail of new picture
5) Immediately after this, dismiss thumbnail strip by pressing active portion (center) of screen before the image preview is displayed.

Actual:
If user dismisses thumbnail strip in camera app immediately after tapping thumbnail, an active camera screen can be seen in a strip where the thumbnail bar was displayed.

Expected:
Incidental taps after selecting thumbnail do not adversely affect UI.

Environmental Variables
Device: Buri v Master M-C Mozilla RIL
Build ID: 20131216040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/f67feb33a974
Gaia: 358cd74fd2b2ef5d541f71a5d53d65d6a7335424
Platform Version: 29.0a1
Firmware Version: V1.2_US_20131115


Notes:
Repro frequency: 3/3, 100%
See attached: screenshot & video clip - http://youtu.be/H7HF8gCS98g
Does this reproduce on 1.2 or 1.3?
Keywords: qawanted
Issue reproduces on Buri in 1.2

Result: If user dismisses thumbnail strip in camera app immediately after tapping thumbnail, an active camera screen can be seen in a strip where the thumbnail bar was displayed.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131217004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/129ad3c335a5
Gaia: 4f53ba8b3628ac311253fc28dfdf66e7ba6832de
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115

_

Issue reproduces on Buri in 1.3

Result: If user dismisses thumbnail strip in camera app immediately after tapping thumbnail, an active camera screen can be seen in a strip where the thumbnail bar was displayed.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131217004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/1f7db4cc788e
Gaia: dca0a3dcf062ce3e422a9c56d141c14543c816fb
Platform Version: 28.0a2
Firmware Version: V1.2_US_20131115
Does this reproduce on 1.1?
Keywords: qawanted
QA Contact: bzumwalt
Issue reproduces on 1.1

Result: If user dismisses thumbnail strip in camera app immediately after tapping thumbnail, an active camera screen can be seen in a strip where the thumbnail bar was displayed.

Environmental Variables
Device: Buri v 1.1 COM RIL
Build ID: 20131217041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bdac595a4e46
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281 
Firmware Version: V1.2_US_20131115
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934366
You need to log in before you can comment on or make changes to this bug.