After the change of a tab text will appear under a scrollable Div

RESOLVED DUPLICATE of bug 953334

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 953334
4 years ago
2 years ago

People

(Reporter: Thomas Schubert, Unassigned)

Tracking

({regression, reproducible})

26 Branch
x86_64
Windows 7
regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8348636 [details]
Screenshot Bugreport.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Open our WebSite in a tab. Open a second tab and if i go back to the first tab text will appear under a scrollable div. 


Actual results:

See attached file (screenshots). Afte go back to the first tab text will appear under my scrollable divs. The text is outside the divs and if i scroll the div text is still there under the div. 


Expected results:

The text below the div should not be displayed. Only after scrolling the text should be displayed only within the div.
(Reporter)

Comment 1

4 years ago
Comment on attachment 8348636 [details]
Screenshot Bugreport.png

I can reproduce this on different PCs with different Windows-OS. On my own PC i have reinstalled firefox but the shown effect is still there.
(Reporter)

Comment 2

4 years ago
In other browsers (IE, Chrome, ...) after the tab was changed the text under the div is not displayed. So i think my html-code is ok.
Thomas, is there a link to the site in question?  It's hard to say what's going on based on a screenshot...
Component: General → Layout: View Rendering
Keywords: testcase-wanted
(Reporter)

Comment 4

4 years ago
Hi Boris, sorry but the site is our business-webapplication and only for people with registration. It is a application with healthcare-data so that i can´t get you an account.
Thomas, can you extract the HTML and CSS of that page into a standalone
testcase that reproduces the problem?

Did the page work correctly in earlier versions of Firefox?
Flags: needinfo?(t.schubert)
(Reporter)

Comment 6

4 years ago
Hello Mats, in earlier versions of firefox the page work correctly. Today i recognize that text was shown right of the div too. Over the scrollbar. I will try to create a standalone version to show you the problem.
Flags: needinfo?(t.schubert)

Comment 7

4 years ago
Created attachment 8351556 [details]
Bug visible in Add-ons-Manager

The bug is also visible in Add-ons-Manager.

Steps to reproduce:
1) Open the Add-ons-Manager (make sure there are enough Add-ons that the list becomes scrollable and that there is a partially visible line of text)
2) Switch to another tab (maybe wait a few seconds?)
3) Switch back to the Add-ons-Manager tab

BTW, this bug is also visible at other places, but this is probably the easiest place to reliably reproduce the bug.

Grafik
DirectWrite aktiviert		false (7.0.6002.23200)
Geräte-ID			0x2a02
GPU #2 aktiv			false
GPU-beschleunigte Fenster	5/5 Direct3D 9
Karten-Beschreibung		Mobile Intel(R) 965 Express Chipset Family
Karten-RAM			Unknown
Karten-Treiber			igdumdx32 igd10umd32
Treiber-Datum			2-26-2009
Treiber-Version			7.15.10.1666
Vendor-ID			0x8086
WebGL-Renderer			Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend		skia
AzureContentBackend		none
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated		0
Does the problem also occur in a Nightly build?
http://nightly.mozilla.org/
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted, reproducible

Comment 9

4 years ago
(In reply to Mats Palmgren (:mats) from comment #8)
> Does the problem also occur in a Nightly build?
> http://nightly.mozilla.org/

No, I can't reproduce it with the nightly built from 
http://hg.mozilla.org/mozilla-central/rev/37516445a0b5

Graphics
Adapter Description		Mobile Intel(R) 965 Express Chipset Family
Adapter Drivers			igdumdx32 igd10umd32
Adapter RAM			Unknown
Device ID			0x2a02
DirectWrite Enabled		false (7.0.6002.23200)
Driver Date			2-26-2009
Driver Version			7.15.10.1666
GPU #2 Active			false
GPU Accelerated ´		Windows	1/1 Direct3D 9
Vendor ID			0x8086
WebGL Renderer			Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend		skia
AzureContentBackend		cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated		0

The only reported difference seems to be the value of AzureContentBackend.
Thanks for your help.  Can you reproduce it in beta and aurora?
http://www.mozilla.org/en-US/firefox/channel/

Comment 11

4 years ago
Created attachment 8358794 [details]
Bug visible in Page Info

I tried with beta and aurora as well and the results are:

				    bug visible in:
			Add-ons-Manager		Page Info*
			---------------		----------
26.0			Yes			Yes
Beta (27.0b5)		No			Yes
Aurora (28.0a2)		No			Yes
Nightly (29.0a1)	No			No


*Steps to reproduce:
1) Open a web page with enough images to create a scrollable list in page info.
2) Right click an image and choose view image info
3) If the glitch is not immediately visible switch to e.g. permissions tab and then back to media tab of page info.
Bug 953334 fixed a clipping bug (that started in FF26) and the fix landed in
beta/aurora on 2014-01-13.  Maybe it fixed this bug too?  Can you test again please?
Flags: needinfo?(andreasjunghw)

Comment 13

4 years ago
I tested it again:
				    bug visible in:
			Add-ons-Manager		Page Info
			---------------		----------
Beta (27.0b5)		No			Yes
Beta (27.0b6)		No			No

So it was apparently fixed by bug 953334.
Flags: needinfo?(andreasjunghw)
Great, thanks for testing!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953334
Keywords: regressionwindow-wanted, testcase-wanted
You need to log in before you can comment on or make changes to this bug.