Cancel Edit Review does not work in MP-stage

VERIFIED FIXED in 2013-12-17

Status

Marketplace
Consumer Pages
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Iulian Timis, Assigned: basta)

Tracking

({regression})

2013-12-17
x86_64
Windows 7
regression
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Load details page for an app in MP-stage (ex. https://marketplace.allizom.org/app/calculator/ )
2. Submit a review.
3. Edit your review and press the Cancel button.

Expected results:
The edit review is canceled and user is redirected to the app details page.

Actual results:
The header changes into "undefined" when the button is pressed and nothing else happens.

Notes/Issues:
Verified on FF29 (Win 7). Issue is not reproducing in MP-dev.
Screencast for this issue http://screencast.com/t/37fsbLvLpg
Log ID: 4e092
The URL becomes "https://marketplace.allizom.org/app/undefined"
And I see this template error:
Uncaught Template render error: Template render error: Template render error: Template render error: Template render error: Template render error: TypeError: Cannot use 'in' operator to search for 'en-US' in undefined 


Basta, lol - is this related to your nunjucks changes?
(Assignee)

Updated

4 years ago
Assignee: nobody → mattbasta
(Assignee)

Comment 2

4 years ago
This is an unrelated regression. The failure is happening because undefined (the value, not the string) is being passed as the slug.

From the looks of it, there's an overly-broad event binding in the Add Review form, which is capturing the cancel event. It fires off its own navigation, but the slug is based on a data attribute from an element that doesn't exist.
(Assignee)

Comment 3

4 years ago
I allegedly fixed this here, but -dev hasn't updated:

https://github.com/mozilla/fireplace/commit/da1d0be7865afd5087449e03437e81e0953650bd
Works on -dev.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

4 years ago
Created attachment 8350133 [details]
android payment.png
(Reporter)

Comment 6

4 years ago
Sorry, wrong window for the attachment.
Verified as fixed in https://marketplace-dev.allizom.org/ on FF29 (Win 7).
Postfix screencast http://screencast.com/t/4raVPQ6pv
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.