Avoid unnecessary Snapshot() copies by clearing the pattern in gfxSurfaceDrawable

RESOLVED DUPLICATE of bug 951216

Status

()

RESOLVED DUPLICATE of bug 951216
5 years ago
5 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
gfxSurfaceDrawable::Draw() sets a gfxPattern(Snapshot()) to the gfxContext's pattern. If the gfxSurfaceDrawable is created by CreateSamplingRestrictedDrawable it will be destroyed before the Snapshot(). This causes the Snapshot to be copied unnecessarily.

If we set the pattern to something else we'll destroy the snapshot before the gfxSurfaceDrawable and save a copy.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951216
You need to log in before you can comment on or make changes to this bug.