Closed Bug 951321 Opened 6 years ago Closed 6 years ago

[B2G][Messages] Create New Message button gets selected but does not open New Message page

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
blocking-b2g 1.3+
Tracking Status
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: nkhristoforov, Assigned: vingtetun)

References

Details

(Whiteboard: [apz_testrun])

Attachments

(3 files)

Attached file Logcat
On the empty Messages app landing page, long-pressing on the screen with two fingers for at least ten seconds results in you not being able to enter the New Message page. You can select the New Message button and it will show up as being selected, but the New Message page does not open. This issue occurs only when APZ is enabled in Settings.

Repro Steps:
1) Updated Buri to BuildID: 20131216140918
2) In Settings > Device Information > More Information > Developer, turn on "Enable APZ for all content," "Remote debugging," and "Gaia debug traces."
3) Press the Home button and open the Messages app.
4) Long-press on the screen with two fingers for at least 10 seconds and select the New Message button.
5) Verify the button gets selected but the New Message page does not open.

Actual:
The New Message button is selected but the New Message page does not open.

Expected:
The New Message page opens.

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20131216140918
Gaia: 504cf9a988cd84760b4040706ccc41e508a97fd2
Gecko: 55b75ce2263e7d2a8cbfdabc7e5206d9caa89f98
Version: 28.0a2
Firmware Version: V1.2_20131115

Repro frequency: 8/10
See attached: Logcat and Screenshot
Attached image Screenshot
(In reply to Nikolai Khristoforov from comment #0)
> Repro Steps:
> 1) Updated Buri to BuildID: 20131216140918

I cannot reproduce on Inari and my Buri has never been dev-capable.

> 2) In Settings > Device Information > More Information > Developer, turn on
> "Enable APZ for all content," "Remote debugging," and "Gaia debug traces."
> 3) Press the Home button and open the Messages app.
> 4) Long-press on the screen with two fingers for at least 10 seconds and
> select the New Message button.
> 5) Verify the button gets selected but the New Message page does not open.
> 
> Actual:
> The New Message button is selected but the New Message page does not open.
> 
> Expected:
> The New Message page opens.
> 
> Environmental Variables:
> Device: Buri 1.3 MOZ
> BuildID: 20131216140918
> Gaia: 504cf9a988cd84760b4040706ccc41e508a97fd2

I can't find this commit in Gaia (see: https://github.com/mozilla-b2g/gaia/commit/504cf9a988cd84760b4040706ccc41e508a97fd2)
This bug was discovered during APZ Testing on a special build developed by Naoki.

Additional Notes: 
This issue only occurs when the "Enable APZ for all content" option is selected on the Developer menu. If the option is not selected, then the New Message page opens. 

Also, a similar issue occurs in the Contacts app. If you long-press with two fingers on the Contacts list, the Contacts setting page and New Contact page do not open even though the button looks selected.
Blocks: gaia-apzc
Rick: to provide a little bit of context, we want to enable APZC on 1.3, and therefore there is a lot of QA going on with this option enabled. That does sometimes mean we'll need to fix bugs by landing workarounds in SMS, and sometimes that there is a Gecko fix.

The first step is to understand why this bug is happening under APZC, and what's happening exactly.
That's a very fun step to reproduce :)

Once the app is in this state the only way to get it working is to restart it.
blocking-b2g: --- → 1.3?
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #6)
> That's a very fun step to reproduce :)
> 
> Once the app is in this state the only way to get it working is to restart
> it.

I was wrong. It works too if you hit the home button and then go relaunch the app.
I wonder if the current state in AsyncPanZoomController is not broken somehow.
Apparently you don't need to stay long. A very quick touch with 2 fingers broke the app for me.
Attached patch bug951321Splinter Review
Seems like we are stuck in a state in GestureEventListener.cpp where we are waiting for pinch gesture. This bug happens only if you don't start a pinch. The issue also dissapears as soon as you start to pinch.
Attachment #8349326 - Flags: review?(bugmail.mozilla)
Attachment #8349326 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/a9182a077284
Assignee: nobody → 21
Status: NEW → ASSIGNED
blocking-b2g: 1.3? → 1.3+
Component: Gaia::SMS → Panning and Zooming
Product: Firefox OS → Core
Target Milestone: --- → mozilla28
https://hg.mozilla.org/mozilla-central/rev/a9182a077284

Target milestone corresponds to when it lands on m-c. Status flags track branch uplifts.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: mozilla28 → mozilla29
You need to log in before you can comment on or make changes to this bug.