Better error messages for SandboxValidationError

RESOLVED DUPLICATE of bug 936384

Status

RESOLVED DUPLICATE of bug 936384
5 years ago
11 months ago

People

(Reporter: gps, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
We /may/ have this bug on file already, but currently if we raise a SandboxValidationError, we get a very unhelpful stack trace. We need to explicitly catch SandboxValidationError somewhere and convert it into a pretty error message, like we do for errors during moz.build evaluation in reader.py.

This likely involves trapping the exception in ConfigStatus.py, so marking as dependent on bug 951010.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 936384

Updated

11 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.