Closed Bug 951375 Opened 11 years ago Closed 10 years ago

[FTE] Cannot pan the First time Experience page

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: nhirata, Assigned: vingtetun)

References

Details

(Keywords: regression, smoketest, Whiteboard: [apz_testrun])

Attachments

(1 file)

Steps to Reproduce:

1. install APZ build, turn APZ on, reboot
2. launch FTE from settings -> device info -> more info -> developer -> launch FTE
3. try to scroll language, try to scroll wifi, for the "about b2g" tap in the email address box and then try to pan.

Expected Results: you can pan up and down
Actual Results: you cannot pan at all.

Additional Notes: there's a few bugs that should not have been closed such as bug 945534.  Filed a generic bug.

Environmental Variables:

Build : 
Gaia      504cf9a988cd84760b4040706ccc41e508a97fd2
Gecko     55b75ce2263e7d2a8cbfdabc7e5206d9caa89f98
BuildID   20131216140918
Version   28.0a2
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013
RIL Type : Mozilla RIL
OS Version: 1.3
Device: Buri
Component: Gaia::First Time Experience → Panning and Zooming
Product: Firefox OS → Core
Assignee: nobody → botond
blocking-b2g: --- → 1.3+
I strongly suspect that some CSS somewhere is setting overflow:hidden on this. See bug 958245 for a similar problem. If you can inspect the styles in gaia-in-firefox then it should be easy enough to diagnose. I couldn't get gaia-in-firefox to respond to clicks so I can't verify myself.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> I strongly suspect that some CSS somewhere is setting overflow:hidden on
> this. See bug 958245 for a similar problem. If you can inspect the styles in
> gaia-in-firefox then it should be easy enough to diagnose. I couldn't get
> gaia-in-firefox to respond to clicks so I can't verify myself.

I'll have a look.

By the way, I also run into issues where gaia-in-firefox doesn't work in very blatant ways (such as not responding to clicks) from time to time. Using the latest nightly to run gaia (or doing a desktop build from the same tree) usually fixes the problem.
I wasn't able to get gaia-in-firefox to work either, but some debugging revealed that the problem is that there are several hidden scrollable elements on top of the things we're trying to scroll in the FTE, which get an APZC and thus eat up our input events.

Looking at the FTE CSS, I can see that visibility:hidden is used to show and hide some things, which is consistent with the symptoms (scrollable elements get a layer and APZC even if they are visibility:hidden).

The proper solution will involve changing the way APZ hit testing works (see bug 928833). Until then, a gaia workaround will be needed, such as using display:none instead of visibility:hidden, or changing the z-order of the hidden elements such that they are below the visible ones.
(In reply to Botond Ballo [:botond] from comment #4)
> I wasn't able to get gaia-in-firefox to work either, but some debugging
> revealed that the problem is that there are several hidden scrollable
> elements on top of the things we're trying to scroll in the FTE, which get
> an APZC and thus eat up our input events.
> 
> Looking at the FTE CSS, I can see that visibility:hidden is used to show and
> hide some things, which is consistent with the symptoms (scrollable elements
> get a layer and APZC even if they are visibility:hidden).
> 
> The proper solution will involve changing the way APZ hit testing works (see
> bug 928833). Until then, a gaia workaround will be needed, such as using
> display:none instead of visibility:hidden, or changing the z-order of the
> hidden elements such that they are below the visible ones.

Does pointer-events: none is enough if frames are not visible ?
Attached patch bug951375.patchSplinter Review
Here is the Gaia workaround.
Attachment #8359174 - Flags: review?(borja.bugzilla)
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #6)
> Created attachment 8359174 [details] [diff] [review]
> bug951375.patch
> 
> Here is the Gaia workaround.

For the record pointer-events: none does not fix the issue, that's why I used display: none.
Attachment #8359174 - Flags: review?(borja.bugzilla) → review+
Component: Panning and Zooming → Gaia::First Time Experience
Product: Core → Firefox OS
Sounds like Vivien is putting in the workaround/fix for this.
Assignee: botond → 21
Uplifted 79a50a1aacad3587758f7dd6cc7e27bdbd3410e5 to:
v1.3: a9eafa98942bb0771629d0a64c13f2444d3010e7
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: