[OPEN C_1.3][User Experience]PIN code function open, and when Restoring factory settings, it's better to verify PIN code

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tong.wei2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0 (Beta/Release)
Build ID: 20120420145725

Steps to reproduce:

1 open PIN code function
2 setting-->device infomation-->more information--> Reset phone


Actual results:

no PIN code verified


Expected results:

it is better to verify PIN code here if PIN code function opened
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
Flags: needinfo?
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
New feature, moving out of 1.3 for now.
Flagging UX for suggestions, is it really helpful to verify PIN code again even if user is already accessing device functions?  BTW "PIN code" here means lock screen password.
blocking-b2g: 1.3? → ---
Flags: needinfo? → needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Comment 2

5 years ago
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #1)
> New feature, moving out of 1.3 for now.
> Flagging UX for suggestions, is it really helpful to verify PIN code again
> even if user is already accessing device functions?  BTW "PIN code" here
> means lock screen password.

It is SIM PIN,not Screen lock.

the User set SIM pin to assure the phone started by self.

It's safe to check it again to make sure it reset to factory default by user himself,if SIM pin was set.
Flags: needinfo?(bhuang)
(Reporter)

Comment 3

5 years ago
and now I think you are right,the user is already accessing device functions.

he maybe have hacked everything already.
If we're talking about SIM PIN, then I don't think the device factory reset should prompt it.  We should keep SIM security independent of device state.
Flags: needinfo?(bhuang)
(Reporter)

Comment 5

5 years ago
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #4)
> If we're talking about SIM PIN, then I don't think the device factory reset
> should prompt it.  We should keep SIM security independent of device state.

yes,agree with that,so I close this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 6

5 years ago
Clearing the ni? for UX since this has been Resolved Invalid.
Flags: needinfo?(firefoxos-ux-bugzilla)
You need to log in before you can comment on or make changes to this bug.