Closed Bug 951563 Opened 6 years ago Closed 6 years ago

The 5th row of app icons is truncated on homescreen with WVGA resolution

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: rudyl, Assigned: rudyl)

References

Details

(Keywords: regression)

Attachments

(4 files)

I am testing Gaia master (v1.4), see the attachment for details.
This happens with WVGA resolution, 800x480.

Gaia      7e8b532adaa3919d3170313a183a4b1f754c6983
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/8d0d66f5c462
BuildID   20131213110652
Version   28.0a2

--
I think it works on v1.1hd, not sure which change caused this regression.
test without bug 906273 please. it could be although I am not pretty sure
Does this reproduce on 1.1 HD? 1.3?
Keywords: qawanted
QA Contact: mvaughan
This issue does NOT reproduce on the Helix 01/03/14 1.1 build.

This issue DOES reproduce on the Helix 01/03/14 1.3 build.

- Helix 1.1 Build -
Environmental Variables:
Device: Helix v1.1 MOZ RIL
BuildID: 20140103042202
Gaia: 2d79d8c461262b4d819fba17a0e8cbc03b36b6b1
Gecko: 7245241c6c8f
Version: 18.0

- Helix 1.3 Build -
Environmental Variables:
Device: Helix v1.3 MOZ RIL
BuildID: 20140103004001
Gaia: ae7d05689b6b9ac4ec6182217dfdef06be28e886
Gecko: d9226a660d52
Version: 28.0a2
Keywords: qawanted
blocking-b2g: --- → 1.3?
This issue started reproducing on the Helix 11/04/13 1.3 build.

- Works -
Environmental Variables:
Device: Helix v1.3 MOZ RIL
BuildID: 20131003040204
Gaia: dc68f530ca7d1b182deef0a3787cfdd8f0778612
Gecko: 0e26e6f12ad9
Version: 27.0a1

- Broken -
Environmental Variables:
Device: Helix v1.3 MOZ RIL
BuildID: 20131004040203
Gaia: 1ac6749e36424124493a1b4c7534f298789bdffd
Gecko: 8f08240128c8
Version: 27.0a1
Do you mean October or November? The build IDs aren't matching up with the first sentence here.
Flags: needinfo?(mvaughan)
Sorry about that... I did mean October. So this issue started reproducing on the Helix 10/04/13 1.3 Build.
Flags: needinfo?(mvaughan)
Tim,

Going forward since this is homescreen, need confirmation that systemsfe will be fixing these bugs.

Thanks
Flags: needinfo?(timdream)
Whiteboard: [FT:System-Platform]
Whiteboard: [FT:System-Platform]
(In reply to Candice Serran (:cserran) from comment #7)
> Going forward since this is homescreen, need confirmation that systemsfe
> will be fixing these bugs.

Yes, thanks for ni'ing.

Again, just because Taipei touched/reported the bug it doesn't make the bug automatically fall under my team :)
Flags: needinfo?(timdream)
Tried to revert change,  dfc678d, made in bug 906273.
Now, you can see the text of the final (5th) row, but it is still clipped by the dock.

And according to the regression window, this issue happened even earlier, around Oct 2013.
After bisecting, I found it is commit b0b587538af823522af806e0ec33c88e78f033b5 that caused this regression.
Blocks: 912515
This is a one-line CSS fix for the label clipping issue.

Cristian, could you review this?
Thanks.
Attachment #8357639 - Flags: review?(crdlc)
Attached image 2014-01-09-15-16-13.png
And here is the screenshot for easy UI review.
Comment on attachment 8357639 [details] [review]
Patch: pull request 15138

Patryk, 

Could you do the UI review?
You may refer to the screenshot for a glance, and this patch applies to WVGA only.

Thanks.
Attachment #8357639 - Flags: ui-review?(padamczyk)
Assignee: nobody → rlu
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8357639 [details] [review]
Patch: pull request 15138

Looks good to me, you only touch the code for those kind of resolutions, perfect. Thanks a lot!
Attachment #8357639 - Flags: review?(crdlc) → review+
Comment on attachment 8357639 [details] [review]
Patch: pull request 15138

Looks good to me, please be advised that Helen Huang (hhuang@mozilla.com) in the Taipei office owns the porting of devices, so if you need further visual design please let her know.
Attachment #8357639 - Flags: ui-review?(padamczyk) → ui-review+
Merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/e38079f27bd38d669c4f1eaf252429285523cb7a

Thanks for the review.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This wasn't fixed correctly. See bug 963338 for a followup.
Depends on: 963338
You need to log in before you can comment on or make changes to this bug.