Command+Shift+P enters full screen instead of opening a new Private Browsing window

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mihaelav, Assigned: entaltoaragon)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(firefox27 affected, firefox28 fixed)

Details

(Whiteboard: [qa-])

(Reporter)

Description

5 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:28.0) Gecko/20100101 Firefox/28.0, build id: 20131217004003
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:27.0) Gecko/20100101 Firefox/27.0, build id: 20131216183647

Command+Shift+P keyboard shortcut enters the browser in fullscreen mode instead of opening a new private browsing window

Steps to reproduce:
1. Launch Firefox using the "an" locale
2. Press Command+Shift+P

Expected result:
A new Private Browsing window opens

Actual result:
Browser enters full screen mode
(Reporter)

Comment 1

5 years ago
In chrome://browser/locale/browser.dtd file there we have:
<!ENTITY fullScreenCmd.macCommandKey "p">
<!ENTITY privateBrowsingCmd.commandkey          "P">
Adding the right Daniel to the bug.
On bug 951208 comment 7 Daniel stated that the change has been landed on aurora:
http://hg.mozilla.org/releases/l10n/mozilla-aurora/an/rev/a1689f02eb22

Since then the problem didn't appear for us. So can we close this bug?
Assignee: nobody → entaltoaragon
Status: NEW → ASSIGNED
status-firefox27: --- → affected
status-firefox28: --- → fixed
Whiteboard: [qa-]
It looks like a fix went in here with the following changesets:

http://hg.mozilla.org/releases/l10n/mozilla-aurora/an/diff/b5cb81ef48ee/browser/chrome/browser/browser.dtd
http://hg.mozilla.org/releases/l10n/mozilla-aurora/an/diff/845938c2e54f/browser/chrome/browser/browser.dtd

I do not see test failures for the latest beta even, so I assume we can get this marked as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.