Mozilla .93 not recognizing/loading installed plug-ins

VERIFIED DUPLICATE of bug 69167

Status

()

--
major
VERIFIED DUPLICATE of bug 69167
17 years ago
16 years ago

People

(Reporter: jeff, Assigned: serhunt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808
BuildID:    2001080814

Just installed Mozilla .93.1 under Mandrake 8.0. Under .91(? whatever came with
the distro) Mozilla had no problems displaying flash documents. Never succeeded
(or tried very hard) in installing Java support. In this build, even though I
now have libflashplayer.so, libjavaplugin_jni.so, libjavaplugin_oji.so,
libnullplugin.so, and ShockwaveFlash.class in the directory
/usr/lib/mozilla/plugins, where Help-> About Plug-ins says it's looking, only
libnullplugin.so is listed as being installed. 

Reproducible: Always
Steps to Reproduce:
1.Look in Konquerer at /usr/lib/mozilla/plugins
2.Help-> About Plug-ins
3.Note that only libnullplugin.so is registering. 

Actual Results:  See step 3. 

Expected Results:  I figure that I should have seen at least the flash and java
plug-ins. Maybe even the ShockWave one.
(Reporter)

Comment 1

17 years ago
Oh, while this may seem obvious, Flash animations are no longer running. 
(Assignee)

Comment 2

17 years ago
Serge, is it another dup of bug 69167 ?

Comment 3

17 years ago
I'm 99% sure this is a dup of 69167. 
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 69167 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
BuildId 2001082722

bug 69167 should be reopen, it doesn't fix the problem..

trying to start with libflashplayer.so installed as plugin,
I get : 

LoadPlugin: failed to initialize shared library
/home/a/flash_linux/libflashplayer.so [/home/a/flash_linux/libflashplayer.so:
undefined symbol: overrideShellClassRec]
LoadPlugin: failed to initialize shared library libXt.so [libXt.so: Ne peut
ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type]
LoadPlugin: failed to initialize shared library libXext.so [libXext.so: Ne peut
ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type]


Seen on Mdk 8.1 beta1.. To duplicate, be sure to remove XFree86-devel package

Comment 6

17 years ago
Better with Buildid 2001082808

Flash plugin is working but I'm still getting some error message :
LoadPlugin: failed to initialize shared library
/home/a/flash_linux/libflashplayer.so [/home/a/flash_linux/libflashplayer.so:
undefined symbol: overrideShellClassRec]

Java is working correctly

Comment 7

17 years ago
In case the patch I've checked in for 69167 is capable enough to find out right
sonames, you will see some error messages just ones,  then mozilla will get
those sonames from prefs "plugin.soname.list". 
Frederic, did you get that message every time you click on Help->About Plugins?

Comment 8

17 years ago
The patch on #69167 fixes this for me as well.  I receive no errors.

Comment 9

17 years ago
When starting 0.9.4 on FreeBSD, I get this:

LoadPlugin: failed to initialize shared library
/usr/X11R6/lib/mozilla/./plugins/libflashplayer.so
[/usr/X11R6/lib/mozilla/./plugins/libflashplayer.so: Undefined symbol "stderr"]
LoadPlugin: failed to initialize shared library
/usr/X11R6/lib/mozilla/./plugins/ShockwaveFlash.class
[/usr/X11R6/lib/mozilla/./plugins/ShockwaveFlash.class: invalid file format]

Comment 10

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.