Firefox hangs (briefly) when displaying an SVG plot

RESOLVED WONTFIX

Status

()

Core
SVG
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: rvitillo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
1) open https://docs.google.com/spreadsheet/ccc?key=0AnHAcptPU0HGdDBnei1JdmZNMUFSXzlMV1hMSkl1Qnc&usp=sharing#gid=1 and wait for the plot to load
2) open a new tab and go back and forth between the two tabs
[clarifying summary to make it clear this isn't an indefinite hang; on my system, we hang for ~1 second.]
[also clarifying to make it clear that this isn't SVG-as-an-image]

So sysprof says we spend all of the hang-time in nsLayoutUtils::PaintFrame

I think this is a result of 2 factors:
 #1 This is a really complex SVG graphic, which takes a little while to repaint.
 #2 We repaint on tab-switch.

I compared to Chrome (blink) and Opera 12.16 (presto), which tab-switch nicely.  I think they do better simply because they don't have behavior #2, apparently. (They must cache the rasterization at some level.)

However, if you force them to repaint by e.g. switching spreadsheet-tabs (to "sheet1" and then back to "chart1") and then wiggle your mouse back and forth between a clickable and non-clickable area (to test whether the page is responding or not -- if it's responding, the cursor will update), you'll see a hang for about the same amount of time where the cursor stops being updated.

So we're not alone in hanging while we paint this graphic; I think it's just that we repaint on tab-switch, while Chrome and Opera do not.
OS: Mac OS X → All
Hardware: x86 → All
Summary: Firefox hangs when displaying a SVG image → Firefox hangs (briefly) when displaying an SVG plot
Doesn't seem to hang on Windows so perhaps this is something that's only on Mac and Linux.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.