offline: downloading newsgroups causing crash

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
--
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Commercial trunk 
2001-08-13-09-trunk/ Nt 4.0
2001-08-13-08-trunk/ linux 2.2, mac 9.0.4

Selecting a newsgroup to download by using the 'download
and sync' window will result in a crash.

I know we can't download newly subscribed newsgroups (see bug
84061). So I tried both with a new profile (& subscribe to
some newsgroups but click on a few of the headers before downloading)
and migrating a existing 4.x profile (that had newsgroups subscribed to)
and both resulted in a crash.

Could not replicate on Linux (as it hangs, instead of a crash)

Reproducibility: most of the time

Steps to reproduce:
1.Create new profile or migrate existing profile
2.Login to imap mail account in messenger
3.Subscribe to a couple newsgroups (if you don't have any already)
4.Click on a newsgroup
5.Click on few of mesgs, to get the bodies of the mesg
6.File|Offline|Download and Sync window
7.Check Newsgroup messages
8 Click select button (if window appears blank, cancel, and repeat)
9.Check the newsgroup you currently selected in step 4.
10.Click ok
11.Click ok in Download and Sync window

result: crash occurs
expected: no crash, mesgs to be downloaded.

Here are the talkback ids:

 -TB34067614X, TB34067854Z, TB34068451K
 -from another computer: TB34068209Q
 -Mac talkback (Same stack trace) TB34068681Q 
   mac error mesg was a "Type 3"
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=34067614

stack trace:
nsMsgSearchSession::GetRunningScope 
 [d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchSession.cpp, 
line 615]
     
nsMsgSearchSession::TimeSliceSerial 
 [d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchSession.cpp, 
line 635]
     
nsMsgSearchSession::TimeSlice 
 [d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchSession.cpp, 
line 624]
     
nsMsgSearchSession::TimerCallback 
 [d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchSession.cpp, 
line 490]
     
nsTimer::Fire 
 [d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 196]
     
nsTimerManager::FireNextReadyTimer 
 [d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimerManager.cpp, line 
117]
     
nsAppShell::Run 
 [d:\builds\seamonkey\mozilla\widget\src\windows\nsAppShell.cpp, line 118]
     
nsAppShellService::Run 
 [d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 425]
     
netscp6.exe + 0x174d (0x0040174d)    
netscp6.exe + 0x121a (0x0040121a)    
netscp6.exe + 0x368f (0x0040368f) 
KERNEL32.dll + 0x1ba06 (0x77f1ba06)
(Reporter)

Comment 1

17 years ago
Linux bug crash? totally different stack trace. had to wait
few minutes before it crashed. Maybe totally different
bug (ie the download is broken in 7-13, bug 90772?)


http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=34069457
(Assignee)

Comment 2

17 years ago
I believe this is because of Navin's fix for a memory leak in search - the
upshot of which is probably that no one is holding onto the search session and
it gets deleted. I'll try to see what I can do about fixing it.

Updated

17 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 3

17 years ago
one more linux crash tb
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=34069916

assuming linux crashes are related.
(Assignee)

Comment 4

17 years ago
no, linux crash is not related - it's an SSL NNTP issue. I've seen that stack
trace in another bug somewhere.

Comment 5

17 years ago
I believe I did the right thing to fix that leak. There was a circular 
reference between searchSession and scopeTermList. 
(Assignee)

Comment 6

17 years ago
yes, fixing the leak was the right thing to do, but a safer way of fixing it
would have been to break the cycle when the search was done. It's my fault for
not pointing that out at the time - I thought about saying something at the
time, but I didn't. My bad.
(Assignee)

Comment 7

17 years ago
Created attachment 45876 [details] [diff] [review]
proposed fix
(Assignee)

Comment 8

17 years ago
fix is to make the news downloader hold onto the search session so that it
doesn't get deleted out from under it.
Status: NEW → ASSIGNED

Comment 9

17 years ago
r=naving newsDownloader get destroyed after the search is over, right
(Assignee)

Comment 10

17 years ago
fix checked in - if newsdownloader leaks,that's a different problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

17 years ago
Commercial builds
2001082703 - win nt 4.0
2001082708 - linux 2.2, mac 9.0.4

Verified downloading newsgroups doesn't result in a crash.
even the strange linux crash I commented all is no longer
there. You can download messages from a newsgroup and 
read them when you are offline.

marking as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.