If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Helix][Marketplace][kelly]The website of marketplace display X when open it.

RESOLVED DUPLICATE of bug 946608

Status

Marketplace
General
RESOLVED DUPLICATE of bug 946608
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

(Blocks: 1 bug)

Points:
---

Details

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:


1. Use a browser to open website "https://marketplace.firefox.com/?mcc=214&mnc=05"  or open marketplace apps on device.
2. Open the marketplace fail and display a "X".



Actual results:


1. Use a browser to open website "https://marketplace.firefox.com/?mcc=214&mnc=05"  or open marketplace apps on device.
2. Open the marketplace fail and display a "X".



Expected results:


1. Use a browser to open website "https://marketplace.firefox.com/?mcc=214&mnc=05"  or open marketplace apps on device.
2. Open the marketplace successfully and display the normal categories of apps
(Reporter)

Comment 1

4 years ago
Created attachment 8349818 [details]
failure log on device using marketplace app.txt


1. open marketplace apps on device.
2. Open the marketplace fail and display a "X".

We found error in the log 

E/GeckoConsole(  982): Content JS ERROR at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=a92c4cc-52aa2e42:5 in anonymous: [amd] Error initializing module:  marketplace
(Reporter)

Updated

4 years ago
Version: 2.0 → 1.3
(Reporter)

Comment 2

4 years ago
Created attachment 8349820 [details]
success log on device using marketplace app.txt


1. open marketplace apps on device.
2. Open the marketplace successfully.
We found proces in the log "Calling navigator.id.watch"


12-12 14:31:44.609: ERROR/GeckoConsole(1645): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1c5298f-52a7b218:5 in anonymous: [login] No previous user detected
12-12 14:31:44.609: ERROR/GeckoConsole(1645): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1c5298f-52a7b218:5 in anonymous: [login] Calling navigator.id.watch
(Reporter)

Updated

4 years ago
Severity: normal → blocker
Priority: -- → P1
(Reporter)

Comment 3

4 years ago
The probability   is about 30%
(Reporter)

Comment 4

4 years ago
Created attachment 8349822 [details]
Use Brooswer on PC to open the marketplace website Failure.txt

1. Use a browser to open website "https://marketplace.firefox.com/?mcc=214&mnc=05"  .
2. Open the marketplace fail and display a "X".

We found error in the log 

[18:06:18.525] GET https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=41f2ae3-52b0a90f [HTTP/1.0 200 Connection established 691ms]
[18:06:18.758] GET https://login.persona.org/include.js [HTTP/1.1 407 authenticationrequired 40ms]
[18:06:18.760] GET https://login.persona.org/include.js [HTTP/1.0 200 Connection established 4364ms]
(Reporter)

Comment 5

4 years ago
Created attachment 8349825 [details]
Use Brooswer on PC to open the marketplace website Success.txt

1. Use a browser to open website "https://marketplace.firefox.com/?mcc=214&mnc=05"  .
2. Open the marketplace successfully

We found process in the log "Calling navigator.id.watch  "

 [login] No previous user detected 
 [login] Calling navigator.id.watch
(Reporter)

Comment 6

4 years ago
Created attachment 8349829 [details]
The fail screenshot of browser on PC.png

The fail screenshot of browser on PC
(Reporter)

Comment 7

4 years ago
Created attachment 8349830 [details]
The success screenshot of browser on PC.png

The success screenshot of browser on PC
(Reporter)

Comment 8

4 years ago
Created attachment 8349834 [details]
fail screen on Device using marketplace app.png

fail screen on Device using marketplace app
(Reporter)

Comment 9

4 years ago
From the logs above, we can found same points in successful logs both in device and browser.

They have the logs as below.
 [login] No previous user detected 
 [login] Calling navigator.id.watch [reply] [−] Comment 6  lecky 2013-12-19 11:35:15 CST 

The website has call the navigator.id.watch to complete login process.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → koi?
(Reporter)

Updated

4 years ago
Flags: needinfo?(kward)
(Reporter)

Updated

4 years ago
Blocks: 946608
This is server-side - this is not actively tracked by blocking-b2g triage.
blocking-b2g: koi? → ---

Comment 11

4 years ago
Adding Wil Clouser to cc list.  Wil  please take a look at this one.
Flags: needinfo?(kward)
> E/GeckoConsole(  982): Content JS ERROR at
> https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=a92c4cc-
> 52aa2e42:5 in anonymous: [amd] Error initializing module:  marketplace

and

> E/GeckoConsole(26123): [JavaScript Error: "TypeError: navigator.l10n is undefined" {file:
> "https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=41f2ae3-52b0a90f" line: 5}]

look like potential problems.  Is comment 3 saying this is reproducible 30% of the time?  What's the device and what browser are you using?
Severity: blocker → normal
Priority: P1 → --
(Reporter)

Comment 13

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #12)
> > E/GeckoConsole(  982): Content JS ERROR at
> https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=a92c4cc-
> 52aa2e42:5 in anonymous: [amd] Error initializing module:  marketplace

and

> E/GeckoConsole(26123): [JavaScript Error: "TypeError: navigator.l10n is undefined" {file:
> "https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=41f2ae3-52b0a90f" line: 5}]

look like potential problems.  Is comment 3 saying this is reproducible 30% of the time?  What's the device and what browser are you using?



It's has no relationship with device, I can reproduce this issue on ZTE Open, LG Fireweb , and use Firefox or Internet Explorer on PC.


But the probability on PC is smaller than on mobile device. I don't know whehter this issue has relationship with mobile network.

Because I found that, if the data icon became from "3G" to "H", this issue could appear easily.
Flags: needinfo?(clouserw)
Our QA lead mentioned they've seen similar problems with poor network connections.  Could be we have a short timeout and give up too easily when loading marketplace assets, although I'm not sure we do any special handling outside of regular HTTP requests.  Could also be the device disconnects pending requests when switching networks or something - either way this is likely going to be tough to diagnose.
Flags: needinfo?(clouserw)
(Reporter)

Comment 15

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #12)
> > E/GeckoConsole(  982): Content JS ERROR at
> https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=a92c4cc-
> 52aa2e42:5 in anonymous: [amd] Error initializing module:  marketplace

and

> E/GeckoConsole(26123): [JavaScript Error: "TypeError: navigator.l10n is undefined" {file:
> "https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=41f2ae3-52b0a90f" line: 5}]

look like potential problems.  Is comment 3 saying this is reproducible 30% of the time?  What's the device and what browser are you using?



It's has no relationship with device, I can reproduce this issue on ZTE Open, LG Fireweb , and use Firefox or Internet Explorer on PC.


But the probability on PC is smaller than on mobile device. I don't know whehter this issue has relationship with mobile network.

Because I found that, if the data icon became from "3G" to "H", this issue could appear easily.
(Reporter)

Comment 16

4 years ago
What's your suggestion to debug this issues continuously?

We think this issue is very serious, because the market can not use if this issue appear, and we must close the marketplace app completely.


Where is the timer you said? Could you tell me ? I want to modify the timeout value and retry it.

(In reply to Wil Clouser [:clouserw] from comment #14)
> Our QA lead mentioned they've seen similar problems with poor network
> connections.  Could be we have a short timeout and give up too easily when
> loading marketplace assets, although I'm not sure we do any special handling
> outside of regular HTTP requests.  Could also be the device disconnects
> pending requests when switching networks or something - either way this is
> likely going to be tough to diagnose.
Flags: needinfo?(clouserw)
I don't know, it's merely speculation.  This bug isn't something we've been able to reliably reproduce.  Also, I think this is a dupe of bug 946608.
Flags: needinfo?(clouserw)
(Reporter)

Comment 18

4 years ago
hi Clouser:
We have seen that you have throw a error in include.js. Could you help to modify it to report a error to Gecko or Gaia instead of throw a error to print it only? If you report a error to Gecko, then we can do something to avoid this issue.


Source:
try{resolved[e]=r.apply(window,n)}catch(a){throw amd_console.error("Error initializing module: ",e),a}}

Destination we want:
try{resolved[e]=r.apply(window,n)}catch(a){throw amd_console.error("Error initializing module: ",e),a}   report error XXXX}


Or could you tell us how to catch a throw message info from gecko or gaia? If we can catch the amd_consoleMessage , we can also do something to process it.
Flags: needinfo?(clouserw)
I still think this is a dupe, but in reply to comment 18, it's the same as https://bugzilla.mozilla.org/show_bug.cgi?id=946608#c15
Flags: needinfo?(clouserw)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946608
You need to log in before you can comment on or make changes to this bug.