Intermittent browser_UITour.js | Panel should have closed after the highlight moved elsewhere. - Didn't expect open, but got it

NEW
Unassigned

Status

()

defect
P3
normal
6 years ago
10 months ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure, leave-open})

unspecified
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test disabled on Linux][stockwell disabled][photon-onboarding])

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=32187284&tree=Fx-Team

Rev4 MacOSX Snow Leopard 10.6 fx-team debug test mochitest-browser-chrome on 2013-12-18 14:47:04 PST for push d549a25bc029
slave: talos-r4-snow-104

16:11:34     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Element should not be null, when checking visibility
16:11:34     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should initially be hidden
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be shown after showHighlight()
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Element should not be null, when checking visibility
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be hidden after hideHighlight()
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be shown after showHighlight()
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be shown after showHighlight()
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Element should not be null, when checking visibility
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be closed/hidden after UITour tab is closed
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Element should not be null, when checking visibility
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Tooltip should be closed/hidden after UITour tab is closed
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | @noautohide on the menu panel should have been cleaned up
16:11:35     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Any pinned tab should be closed after UITour tab is closed
16:11:35     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Starting test_highlight_customize_auto_open_close
16:11:35     INFO -  ++DOCSHELL 0x1729ab380 == 40 [pid = 889] [id = 6778]
16:11:35     INFO -  ++DOMWINDOW == 197 (0x15dfa3f08) [pid = 889] [serial = 17147] [outer = 0x0]
16:11:35     INFO -  ++DOMWINDOW == 198 (0x15dfafc48) [pid = 889] [serial = 17148] [outer = 0x15dfa3f08]
16:11:35     INFO -  [Parent 889] WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 265
16:11:35     INFO -  ++DOMWINDOW == 199 (0x168e53968) [pid = 889] [serial = 17149] [outer = 0x15dfa3f08]
16:11:37     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should be shown after showHighlight() for fixed panel items
16:11:37     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Panel should have opened
16:11:37     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Highlight should move to the appMenu button
16:11:37  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js | Panel should have closed after the highlight moved elsewhere. - Didn't expect open, but got it
16:11:37     INFO -  Stack trace:
16:11:37     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_isnot :: line 709
16:11:37     INFO -      JS frame :: chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js :: checkPanelIsClosed :: line 203
16:11:37     INFO -      JS frame :: chrome://mochitests/content/browser/browser/modules/test/browser_UITour.js :: waitForElementToBeVisible/< :: line 36
16:11:37     INFO -      JS frame :: chrome://mochitests/content/browser/browser/modules/test/head.js :: <TOP_LEVEL> :: line 23
16:11:37     INFO -      JS frame :: chrome://mochitests/content/browser/browser/modules/test/head.js :: <TOP_LEVEL> :: line 19
16:11:37     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
Disabling on Linux for too many intermittent failures.
Whiteboard: [test disabled on linux] [leave open]
This test has been disabled on Linux for too many intermittent failures, could you take a look at some point so we can get the test coverage back? :-)
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Ed Morley (Away at DashCon; back on 27th Jan) [:edmorley UTC+0] from comment #44)
> This test has been disabled on Linux for too many intermittent failures,
> could you take a look at some point so we can get the test coverage back? :-)

I would like to, but I'm a little bit snowed under right now. I will try to get to it the coming week. Thank you for flagging me; I'll leave the needinfo for now.
OK, it's clear to me I'm not getting at this, in part because I don't know this code at all. That wouldn't be so bad because the test is disabled on Linux, but as of today it's also failing on Windows. Matt, can you look at what could have caused that? Given the frequency, it looks to me like the regression range is going to be less than 24 hours, and on a Sunday... so hopefully that should be pinpointable.
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(MattN+bmo)
I can take a look at some point especially if it increases in volume. Leaving the flag as a reminder. I was surprised you offered to fix this in the first place :)
OS: Mac OS X → All
Hardware: x86_64 → All
Moving open UITour bugs to Firefox::Tours. Filter on firefox-tours-20150121.
Component: General → Tours
There are known panel testing issues with Linux and this test was only disable on Linux but also stopped occurring on OS X so I don't think we're going to do anything about this.

We're also going to need to rewrite these tests for e10s which will hopefully fix intermittents too…
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → WONTFIX
Hello from e10s.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I am helping my friend Kyle try to get started contributing to Firefox. He is going to try jumping into the deep end a bit by starting with this bug.
Assignee: nobody → kylenosar
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Assignee: kylenosar → nobody
Keywords: leave-open
Whiteboard: [test disabled on linux] [leave open] → [test disabled on Linux][stockwell disabled]
osx debug is the primary failure here- 25 failures in the last week:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=951965

this has been a 15+ failure test for the last 6 weeks, we should at least keep an eye on this.
This looks like it ticked up sometime in the last few days, and is now failing at least once on close to half of all pushes (!). I can only assume it has something to do with the changes we made for onboarding. Ricky, can you take a look? Did we add more tests to this file that should have been put in a separate test file, or something?
Flags: needinfo?(rchien)
Status: REOPENED → NEW
Flags: needinfo?(rchien) → qe-verify-
Whiteboard: [test disabled on Linux][stockwell disabled] → [test disabled on Linux][stockwell disabled][photon-onboarding][triage]
From the comment 237 & comment 239, the intermittent rate increased around the recent days and it failed at here: http://searchfox.org/mozilla-central/rev/67f38de2443e6b613d874fcf4d2cd1f2fc3d5e97/browser/components/uitour/test/browser_UITour.js#140
Flags: needinfo?(fliu)
Whiteboard: [test disabled on Linux][stockwell disabled][photon-onboarding][triage] → [test disabled on Linux][stockwell disabled][photon-onboarding]
Comment on attachment 8909197 [details]
Bug 951965 - Make sure checking PanelUI.panel state after the popuphidden event,

https://reviewboard.mozilla.org/r/180694/#review185856

::: commit-message-ae398:3
(Diff revision 1)
> +Bug 951965 - Make sure checking PanelUI.panel state after the popuphidden event, r?MattN
> +
> +This commit makes sure checking PanelUI.panel state is "closed" after the popuphidden event so as to avoid the intermittent fialure because of the too early checking.

Hi Matt,

Pushed to TRY to run 10x on the win/linux/osx platform and the results are good [1], thanks

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=59fa1b518ad5bd39eb7950f4545fa79975ea0588
Attachment #8909197 - Flags: review?(MattN+bmo) → review?(gijskruitbosch+bugs)
Comment on attachment 8909197 [details]
Bug 951965 - Make sure checking PanelUI.panel state after the popuphidden event,

https://reviewboard.mozilla.org/r/180694/#review185892
Attachment #8909197 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs from comment #250)
> Comment on attachment 8909197 [details]
> Bug 951965 - Make sure checking PanelUI.panel state after the popuphidden
> event,
> 
> https://reviewboard.mozilla.org/r/180694/#review185892
Thanks
Flags: needinfo?(fliu)
Keywords: checkin-needed
I already landed this on autoland: https://hg.mozilla.org/integration/autoland/rev/76264c3da3f9

I don't know why pulsebot didn't comment.
Keywords: checkin-needed
(In reply to :Gijs from comment #252)
> I already landed this on autoland:
> https://hg.mozilla.org/integration/autoland/rev/76264c3da3f9
> 
> I don't know why pulsebot didn't comment.
Thank you. I didn't notice that either...
You need to log in before you can comment on or make changes to this bug.