[B2G][Helix][Homescreen][wangchao]When add a url icon to homescreen, it can not delete the icon and make dock Invalid.

RESOLVED DUPLICATE of bug 923393

Status

P2
blocker
RESOLVED DUPLICATE of bug 923393
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8349826 [details]
screenshot.png

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

Repro step:
1.open browser, enter a url and wait the page is correct loaded.
2.click the star at the bottom right and add the url to homescreen.
3.go to homescreen and press the url icon for a log time. It enter 'edit' mode.
4.delete the icon


Actual results:

4.the icon can not be deleted.
If you press home to exit "edit" mode, the dock area is invaild. If you once press other icon to delete, it recovered. 


Expected results:

4.the icon can be deleted.
(Reporter)

Comment 1

5 years ago
Hi All"
As i trace the code, i found it was injected by 
https://bugzilla.mozilla.org/show_bug.cgi?id=896873

Merged into master:
https://github.com/mozilla-b2g/gaia/commit/e217f6e01d424be2d5b31bd5fcf53bc7915a40a2
if delete line:577-579
this issue is gone.

Thanks!
Severity: normal → blocker
Priority: -- → P2
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
(Reporter)

Comment 2

5 years ago
Hi All:

   If i rebase the patch for bug: "https://bugzilla.mozilla.org/show_bug.cgi?id=896873". I do not know whether it will cause other problem.

   So we need you help to review for this.

Thanks!
(Reporter)

Comment 3

5 years ago
Hi All:

For merged code:
Merged into master:
https://github.com/mozilla-b2g/gaia/commit/e217f6e01d424be2d5b31bd5fcf53bc7915a40a2

As well as merged into V1.1HD.
if just delete line:577-579, this problem is disappeared.

But we afraid that bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=896873
will turn up again.

So, we have to check and make a test for this.

Thanks!
Evelyn,
can you follow up on this?
Flags: needinfo?(wchang) → needinfo?(ehung)
This works fine for me by the way.

Reporter, please state your software version and it needs to be a mozilla version.
Flags: needinfo?(lecky.wanglei)
I detected this issue two months ago and I fixed here bug 923393. But I don't know which device are you using, release, gecko, etc.. Please give us more info
Duping then.

That said, this is quite a failure than bug 923393 was not made koi+ back when it was fixed, and that leo? was rejected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923393

Updated

5 years ago
Flags: needinfo?(ehung)
You need to log in before you can comment on or make changes to this bug.