Assertion failure: compilationLockOwner != PR_GetCurrentThread(), at vm/Runtime.cpp:997

VERIFIED FIXED in mozilla29

Status

()

--
critical
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: gkw, Assigned: bhackett)

Tracking

(Blocks: 1 bug, {assertion, regression})

Trunk
mozilla29
x86_64
Mac OS X
assertion, regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8349843 [details]
Stack from Crash Reporter

Assertion failure: compilationLockOwner != PR_GetCurrentThread(), at vm/Runtime.cpp is an assertion that has hard-to-reproduce testcases, and which appeared fairly recently (probably in the past weeks?).

Not sure where this lives, setting needinfo? from jandem in case he has any ideas. :)
Flags: needinfo?(jdemooij)
Brian, do you have any idea what's going on?
Flags: needinfo?(jdemooij) → needinfo?(bhackett1024)
I think the problem is GlobalObject::addIntrinsicValue taking the compilation lock, and then we try to take the operationCallbackLock as well.
(Assignee)

Comment 3

5 years ago
Created attachment 8350311 [details] [diff] [review]
patch

I don't think there is any place we take the compilation lock while holding the operation callback lock, so we can just fixup the lock ordering constraints.
Assignee: nobody → bhackett1024
Attachment #8350311 - Flags: review?(jdemooij)
Flags: needinfo?(bhackett1024)
Comment on attachment 8350311 [details] [diff] [review]
patch

Review of attachment 8350311 [details] [diff] [review]:
-----------------------------------------------------------------

Glad it's this simple.
Attachment #8350311 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/6296ca67d80b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
I haven't seen this since.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.