Closed Bug 952034 Opened 9 years ago Closed 6 years ago

Test failure 'Modal dialog has been found and processed' in /restartTests/testAddons_installFromFTP/test1.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P3)

defect

Tracking

(firefox28 wontfix, firefox29 wontfix, firefox30 wontfix, firefox31 wontfix, firefox32 wontfix, firefox33 wontfix, firefox34 affected, firefox35 affected, firefox36 affected, firefox-esr24 wontfix, firefox-esr31 affected)

RESOLVED INVALID
Tracking Status
firefox28 --- wontfix
firefox29 --- wontfix
firefox30 --- wontfix
firefox31 --- wontfix
firefox32 --- wontfix
firefox33 --- wontfix
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected
firefox-esr24 --- wontfix
firefox-esr31 --- affected

People

(Reporter: andrei, Unassigned)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Module:    testInstallAddonFromFTP
Test:      /restartTests/testAddons_installFromFTP/test1.js    
Failure:   Modal dialog has been found and processed
Branches:  mozilla-aurora
Platforms: WIndows Vista

Just 1 occurrence: 
http://mozmill-daily.blargon7.com/#/remote/report/ca1869364f98dd0de71202e01ed0162b
Happened today on Mac OSX 10.9 with Firefox 28.0b1 es-ES:
http://mozmill-release.blargon7.com/#/remote/report/0906e2c8b6f223d6588987bcd1cfb030
OS: Windows Vista → All
Happened today on Mac OSX 10.8 with Firefox 28.0b1 en-GB:
http://mozmill-release.blargon7.com/#/remote/report/0906e2c8b6f223d6588987bcd1cfb030
Failed today on 

Firefox Beta 28.0 de - Windows XP 32 (mm-win-xp-32-1)
http://mozmill-release.blargon7.com/#/remote/report/e248c845ffb052c61b3635551b58fdfa

Firefox Beta 28.0 en-GB - Windows xp 32 (mm-win-xp-32-3)
http://mozmill-release.blargon7.com/#/remote/report/e248c845ffb052c61b3635551b58f097

Forefox Beta 28.0 pt-BR - Windows 7 32 (mm-win-7-32-4)
http://mozmill-release.blargon7.com/#/remote/report/e248c845ffb052c61b3635551b58f00a
Failed with Nightly (20140323030203) de on Windows XP 32

Report:
http://mozmill-daily.blargon7.com/#/remote/report/97976110c92e838016d17f7fb219fc20
Failed again twice with Nightly and Aurora on windows:
http://mozmill-daily.blargon7.com/#/remote/failure?app=All&branch=All&platform=All&from=2014-04-07&to=&test=%2FrestartTests%2FtestAddons_installFromFTP%2Ftest1.js&func=testInstallAddonFromFTP
Also when it fails with this we can get aborted testrun too, because when we fail to handle the modal and we close the application with the modal frozen we get:
>05:12:40   File "c:\jenkins\workspace\mozilla-aurora_remote\mozmill-env-windows\python\lib\site-packages\mozmill\__init__.py", line 508, in handle_disconnect
>05:12:40     self.stop_runner()
>05:12:40   File "c:\jenkins\workspace\mozilla-aurora_remote\mozmill-env-windows\python\lib\site-packages\mozmill\__init__.py", line 562, in stop_runner
>05:12:40     raise Exception('client process shutdown unsuccessful')
>05:12:40 Exception: client process shutdown unsuccessful
Right, and that's what will be fixed with bug 794020 in Mozmill 2.1.
This might be related: http://mozmill-daily.blargon7.com/#/remote/report/91f18c799f60f33fc05d03749c4257ef 
One failure on Mac for testAddonInstalled with the error message, AddonsManager_isAddonInstalled: Add-on has been specified. - got 'undefined'.

Should I file a new bug for that?
Flags: needinfo?(hskupin)
Something went wrong here with the installation of the extension. But it's not related to this bug given that test1.js was successful. So yes, a new bug has to be filed. I'm sure Andreea, our infra duty this week, will get it filed shortly. If not feel free to do it later today.
Flags: needinfo?(hskupin)
I believe we can keep track of that failure in bug 974930, which is a more general one as we have several tests affected with this error from the library method.
(In reply to Andreea Matei [:AndreeaMatei] from comment #17)
> I believe we can keep track of that failure in bug 974930, which is a more
> general one as we have several tests affected with this error from the
> library method.

Not really. While we have a same error message, the cause is probably different. In this case, we first fail to manage the Modal dialog required to install the Addon. The second failure is thus normal. Test2 does not have the addon installed.

We had another one:
http://mozmill-release.blargon7.com/#/remote/report/0bd22723d1fdbb446269f765b9cf821e

Most of these are on windows.

I've run lots of testruns last weeks and I remember seeing (intermittently) both these failures:
http://mozmill-daily.blargon7.com/#/remote/failure?app=All&branch=All&platform=All&from=2014-01-28&test=%2FrestartTests%2FtestAddons_installFromFTP%2Ftest1.js&func=testInstallAddonFromFTP
Not sure if in this particular test, or in another Addons test. The interesting part is that I saw them on OSX, while these reported ones are all on Windows (with 1 expection on Linux)
Interestingly we have no recorded failure for the whole month of October.
Failed again in November several times, mostly on Linux machines this time.
This is network related, we try to open an remote addon, adn when the resource is loaded the modal dialog for installing it will prompt, but when it won't load, the Modal dialog will just not open, that happend here. 
http://hg.mozilla.org/qa/mozmill-tests/file/76a43120f67d522847b4ada0ed05d19f3d0b03b0/firefox/tests/remote/restartTests/testAddons_installFromFTP/test1.js#l20
Would the insertion of a waitForPageLoad() call help here? Not sure if that works with other MIME types. If it does we can see that the page was not loaded.
Removing keyword, since it's intended for test failures that are seen on Treeherder (and otherwise you'll end up with bugs being marked as worksforme if no occurrences are seen on Treeherder).
Mozmill tests have been superseded by Marionette tests.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.