Closed Bug 952046 Opened 6 years ago Closed 5 years ago

Intermittent TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | testSessionHistory | The Toolbar title is ...( Amazon | Bing | Google | Twitter | Wikipedia | Yahoo )...

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

Android 4.0 Panda mozilla-inbound opt test robocop-4 on 2013-12-18 20:40:29 PST for push d86702f2170c

slave: panda-0554

https://tbpl.mozilla.org/php/getParsedLog.php?id=32199289&tree=Mozilla-Inbound

12/18/2013 20:52:23: WARNING: Automation Error: updateSUT.py: We have tried to connect 1 time(s) after trying to update.
63 INFO TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | The Toolbar title is  - got about URI scheme - Wikipedia, the free encyclopedia, expected
12-18 21:07:04.507 I/Robocop ( 3415): 63 INFO TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | The Toolbar title is  - got about URI scheme - Wikipedia, the free encyclopedia, expected
I have absolutely no idea why this test would try to go to Wikipedia, and without using the test framework methods (there is no assertions on the url). My best guesses:
  * The test was manually interrupted
  * The test was not on a clean profile and
    * Somehow hit back, which would go back in history to Wikipedia
    * Somehow clicked on Wikipedia in the history/top sites/etc.
comment 0 may have gone to Wikipedia because it selected the Wikipedia option off of the search suggestions page (the "about URI scheme" page on Wiki is what you get when you search for "about:home"). I'm not sure why this might have happened though.

comment 1 is missing some useful debug output, being on Aurora, so I'm not sure what might have happened.
Updated the title to account for the dupe from bug 961619 (Yahoo loaded). I also added all of the search providers to be safe.
Summary: Intermittent TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | The Toolbar title is - got about URI scheme - Wikipedia, the free encyclopedia, expected → Intermittent TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | testSessionHistory | The Toolbar title is ...( Amazon | Bing | Google | Twitter | Wikipedia | Yahoo )...
comment 8 and comment 9 might be caused by bug 962103 comment 28 and their logs may be from a different cause than the intermittent we have been receiving. The troublesome patch has since been backed out.
re comment 8, the suggestion button was definitely hit:

16:16:45     INFO -  02-27 16:16:36.085 I/GeckoBrowserApp( 3185): Recording search: Yahoo, barsuggest
16:16:45     INFO -  02-27 16:16:36.085 D/GeckoHealthRec( 3185): Recording search: yahoo, barsuggest (16128, 1).

Curiously, found in the logs each time the keyboard is used:

16:16:45     INFO -  02-27 16:16:34.351 I/LatinIME( 1539): InputType.TYPE_NULL is specified
16:16:45     INFO -  02-27 16:16:32.601 W/LatinIME( 1539): Unexpected input class: inputType=0x00000000 imeOptions=0x00000000

And slightly before the search suggestion is hit (and subsequent failure):

16:16:45     INFO -  02-27 16:16:30.453 D/InputEventConsistencyVerifier( 3185): KeyEvent: ACTION_UP but key was not down.
16:16:45     INFO -  02-27 16:16:30.453 D/InputEventConsistencyVerifier( 3185):   in com.android.internal.policy.impl.PhoneWindow$DecorView@412450d0
16:16:45     INFO -  02-27 16:16:30.453 D/InputEventConsistencyVerifier( 3185):   0: sent at 590707000000, KeyEvent { action=ACTION_UP, keyCode=KEYCODE_BACK, scanCode=0, metaState=0, flags=0x8, repeatCount=0, eventTime=590707, downTime=590707, deviceId=-1, source=0x101 }

This key press appears to be the action to hide the HomePager [1]. Then we assert that the HomePager is not longer visible, enter "about:home", but Yahoo shows up instead. Perhaps our "is HomePager visible?" assertions are incorrect, we remained in editing mode, and ended up clicking the search suggestion instead of some other UI widget.

[1]: https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/tests/testAboutHomeVisibility.java?rev=1d2fa2d09f5b#36
re comment 9, again we see the barsuggest recording:

02:45:19     INFO -  03-03 02:45:11.125 I/GeckoBrowserApp( 3530): Recording search: Amazon.com, barsuggest
02:45:19     INFO -  03-03 02:45:11.125 D/GeckoHealthRec( 3530): Recording search: amazondotcom, barsuggest (16132, 1).

And again we see:

02:45:19     INFO -  03-03 02:45:09.359 I/LatinIME( 1543): InputType.TYPE_NULL is specified
02:45:19     INFO -  03-03 02:45:09.359 W/LatinIME( 1543): Unexpected input class: inputType=0x00000000 imeOptions=0x00000000

But I don't see any issues with key presses. Perhaps robocop is just missing the go button? :\ We might be able to solve this by sending the "Enter" key instead, but it's preferable not to.
bug 946656 comment 114 is Yahoo, bug 946656 comment 115 is Google.

re Yahoo:

14:43:20     INFO -  03-07 14:42:57.515 D/GeckoLayerClient( 3684): Aborting draw due to resolution change: 1.0 != 1.3061224

repeats several times and is a bit suspicious. If the resolution is changing, perhaps our Robotium clicks go to the wrong place (i.e. a search engine). The other tests do not seem to have this output (though it might be caused by clicking the search engine. It prints first, before we appear to load the page, but the logs may not be in order). Note that GeckoLayerClient should not be affecting the Android front-end however.

re Google, the same shenanigans are present:

14:54:04     INFO -  03-11 14:53:48.757 D/GeckoLayerClient( 3705): Aborting draw due to resolution change: 1.0 != 1.3061224

However, I checked and other pushes that do not fail also contain these logs so I'm not sure it means anything.
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.