H264/WebM: Firefox take the first format on the list. Should take webM if he could

RESOLVED DUPLICATE of bug 869813

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 869813
5 years ago
5 years ago

People

(Reporter: vulcain, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206152142

Steps to reproduce:

1) Launch Firefox 
2) Go to this page http://camendesign.co.uk/code/video_for_everybody/test.html
3) Firefox select the first format: H264
4) Go to https://www.mozilla.org/fr/mission/
5) Firefox select the first format: webM

4 952,22 Ko for WebM
5 381,71 Ko for H264


Actual results:

Firefox always select the first format.
For https://www.mozilla.org/fr/mission/, it's 
<source src="//videos-cdn.mozilla.net/brand/Mozilla_2011_Story.webm" type="video/webm">
                  <source src="//videos-cdn.mozilla.net/brand/Mozilla_2011_Story.ogv" type="video/ogg; codecs=&#34;theora, vorbis&#34;">
                  <source src="//videos-cdn.mozilla.net/brand/Mozilla_2011_Story.mp4" type="video/mp4">
For http://camendesign.co.uk/code/video_for_everybody/test.html, it's 
<source src="http://clips.vorwaerts-gmbh.de/VfE_html5.mp4" type="video/mp4"  /><!-- Safari / iOS, IE9 -->
	<source src="http://clips.vorwaerts-gmbh.de/VfE.webm"      type="video/webm" /><!-- Chrome10+, Ffx4+, Opera10.6+ -->
	<source src="http://clips.vorwaerts-gmbh.de/VfE.ogv"       type="video/ogg"  /><!-- Firefox3.6+ / Opera 10.5+ -->

As you can see, Firefox take the first one. But historically, by a bug on iOS 3 (see http://diveintohtml5.info/video.html#markup ) web developer give always the first place for mp4. 
And H264 are not often the smaller:
http://camendesign.co.uk/code/video_for_everybody/test.html : for 640*360 video:=> 4 952,22 Ko for WebM and 5 381,71 Ko for H264
https://www.mozilla.org/fr/mission/ for a 640px × 360px video:=> 7 387,38 Ko for WebM  and 43 906,39 Ko for H264


Expected results:

Firefox should select and read WebM format when he have the choice.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 869813
You need to log in before you can comment on or make changes to this bug.