Closed Bug 952099 Opened 8 years ago Closed 8 years ago

[Dialer] Two taps on hang up button necessary to stop a call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v1.3 fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: whimboo, Assigned: etienne)

References

Details

(Keywords: regression)

Attachments

(3 files)

Firefox OS 1.2 on Alcatel One Touch Fire.

When I'm in a call and want to stop it, I have to press twice on the hang up button to actually stop the call. The first press doesn't cause any reaction of the phone. I had the situation already multiple times that I noticed a couple of minutes later that the call is still active.

I think this is a serious regression and not sure why it hasn't been reported yet. At least I'm not able to find a bug about it.

Steps:

1. Start a call
2. After a while tap on the hang up button

The call doesn't stop after tapping one time at the button.  You will have to press twice on it.
It could be SIM-specific if it hasn't been reported yet.

Can someone on a different SIM in US see if we can reproduce?
see if this repros on US SIM
Flags: needinfo?(jhammink)
QA Contact: gbennett
This does not repro on a US SIM for the latest Buri 1.2 comRIL build. Attempted repro while in and not in lockscreen, after the phone went to sleep, and tapping the power button off and on.

Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131219004002
Gaia: c82c957e9d4078cd4043de6b7d21a2667a73adf7
Gecko: 7958c38c7afd
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: qawanted
I have a SIM card from Congstar (Germany) just in case it matters. I'm updating to todays Nightly build now to see if it still reproduces.
Sadly I'm currently blocked on the 20131209 Nightly build due to bug 952196. So I cannot test with the latest Nightly for now.
Garrett - which SIM did you try this on?   

Be sure to try on a few different ones if you can.

Henrik - please also let us know if this appears once you get unblocked.
Flags: needinfo?(gbennett)
Flags: needinfo?(jhammink)
I thought I reproduced it, but then I realized that the hang up button is just hard to hit correctly. Wonder if we have an event fluffing issue...
(In reply to Etienne Segonzac (:etienne) from comment #7)
> I thought I reproduced it, but then I realized that the hang up button is
> just hard to hit correctly. Wonder if we have an event fluffing issue...

I don't think it would be event fluffing if it's reproducing 1.2, as to my understanding, we preffed off event fluffing on 1.2.
So Vivien showed me a "flugging debug" build, and the hang up button "zone" isn't reaching the bottom of the screen.

Switching from margin to padding for the button should help here.
Attached image hit zones
Attached file Patch proposal
Assignee: nobody → etienne
Attachment #8350645 - Flags: review?(ferjmoreno)
Attached image 1220130949.jpg
I attempted repro on today's build with all of the SIMs in the attached picture and could not repro. The SIM w/o a card on the top left (AT&T) is the one I use daily.
Flags: needinfo?(gbennett)
I'm still on this old build and haven't upgraded. As what I noticed today is that I'm not always trapped by this issue. Whenever I start a call and stop it before the other side accepts it, a single tap stops the call. Same when I call someone. But whenever I get a call and talk for a while this problem occurs. It might be due to the screen turns off in between. I haven't checked that yet when I call someone. So I will have a further look at it in the next couple of days.
Based on Etienne's comments of this potentially being a fluffing issue & knowledge that this was tested on an older 1.2 build, I think this is a blocker for 1.3, rather than 1.2. The reason for this is that event fluffing was turned off in 1.2 very late in the release, so that would mean on the latest 1.2 build, you won't see this bug. However, this will be present on 1.3, as event fluffing is enabled on 1.3.

As such, I'm moving this to 1.3?
blocking-b2g: koi? → 1.3?
QAWANTED to confirm this again on 1.3
Keywords: qawanted
Comment on attachment 8350645 [details] [review]
Patch proposal

redirecting
Attachment #8350645 - Flags: review?(ferjmoreno) → review?(anthony)
Comment on attachment 8350645 [details] [review]
Patch proposal

Sorry for the late review. I've been on vacations for the last two weeks :). I'm back now.

Looks good to me and works ok. Thanks Etienne!
Attachment #8350645 - Flags: review?(anthony) → review+
I doesn't reproduce on 1.3 builds with US SIM Cards, tested with AT&T and T-Mobile
The call stops after tapping the hang up button once

Device: Buri 1.3 MOZ
BuildID: 20140107004001
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Gecko: 71ad7ff30010
Version: 28.0a2
Firmware Version:v1.2_20131115
Keywords: qawanted
Without a clear way to reproduce, we aren't to block on this. We can consider the patch for approval though.
blocking-b2g: 1.3? → -
Comment on attachment 8350645 [details] [review]
Patch proposal

Fernando: Sorry to clear the flag. I talked with Etienne yesterday and asked him to use real buttons elements here. I should have updated the bug at that time.
Attachment #8350645 - Flags: review+
Comment on attachment 8350645 [details] [review]
Patch proposal

Ready for a new round of review :)
Attachment #8350645 - Flags: review?(anthony)
Comment on attachment 8350645 [details] [review]
Patch proposal

Nice simplification! /me likey
Attachment #8350645 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/f400efc804366c7b7cf5476d1d5d325e6651ee71
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Depends on: 960068
I would like to verify this fix but I have absolutely no idea how to upgrade my Alcatel One Touch Fire to the latest version. Whether on Nightly nor 1.3. I always get the failure that not sufficient disk space is available even by using the full flash script.
blocking-b2g: - → 1.3?
(In reply to Henrik Skupin (:whimboo) from comment #24)
> I would like to verify this fix but I have absolutely no idea how to upgrade
> my Alcatel One Touch Fire to the latest version. Whether on Nightly nor 1.3.
> I always get the failure that not sufficient disk space is available even by
> using the full flash script.

I don't think that makes an argument to block on this. comment 19's rationale still stands, although we can consider this for approval.
blocking-b2g: 1.3? → -
Can anyone please help me in how to get an actual build on the phone. Whereever I ask I don't get an answer, which is a bit disappointing. I cannot dogfood when I have to remain on a 20131115 v1.2 build on that phone.
(In reply to Henrik Skupin (:whimboo) from comment #26)
> Can anyone please help me in how to get an actual build on the phone.
> Whereever I ask I don't get an answer, which is a bit disappointing. I
> cannot dogfood when I have to remain on a 20131115 v1.2 build on that phone.

Ping Naoki offline - he could give you a run down on how to get a build on your phone.
(In reply to Jason Smith [:jsmith] from comment #25)
> I don't think that makes an argument to block on this. comment 19's
> rationale still stands, although we can consider this for approval.

This is still an ongoing and really annoying behavior I hit each time in the last couple of days when I tried to stop a call with a 1.3 version of B2G from Jan 24th. In most of the cases it was an incoming call. We should really get this fixed for the 1.3 release. It's a behavior users will clearly not accept.
blocking-b2g: - → 1.3?
Flags: needinfo?(etienne)
(In reply to Henrik Skupin (:whimboo) from comment #28)
> (In reply to Jason Smith [:jsmith] from comment #25)
> > I don't think that makes an argument to block on this. comment 19's
> > rationale still stands, although we can consider this for approval.
> 
> This is still an ongoing and really annoying behavior I hit each time in the
> last couple of days when I tried to stop a call with a 1.3 version of B2G
> from Jan 24th. In most of the cases it was an incoming call. We should
> really get this fixed for the 1.3 release. It's a behavior users will
> clearly not accept.

What information is needed?
Should I just ask for approval and uplift my fix, or is the fix not working? If so we should reopen this bug.
Flags: needinfo?(etienne)
I do not run nightly on my fx device but v1.3. So yes, it is not fixed for that branch because the patch never landed there. If we have to go via an approval then this would be great, yes.
Comment on attachment 8350645 [details] [review]
Patch proposal

DOM/CSS change that landed a while ago without any regression :)
Attachment #8350645 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8350645 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
You need to log in before you can comment on or make changes to this bug.