Closed Bug 952110 Opened 8 years ago Closed 8 years ago

Crash of FF when it installs my extension (HebrewCalendar)

Categories

(Core :: General, defect)

26 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: igor.zc, Assigned: m_kato)

References

Details

Crash Data

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

I install extension Hebrew Calendar (http://hcalendar.googlecode.com/files/hcalendar1.0.6.3-fx%2Btb.xpi)

links:
extension: http://hcalendar.googlecode.com/files/hcalendar1.0.6.3-fx%2Btb.xpi
crash report: https://crash-stats.mozilla.com/report/index/b8de3476-20b7-4368-b969-f56fe2131217



Actual results:

crash


Expected results:

Extension should be installed and show data in status bar.
Additional notes:
1. Seems, crash started from FF24.
2. When update FF26 to "previous version": installed HebrewCalendar extension works.
Are you sure this started in FF24 and not FF23? From the crash report, we're crashing here calling strlen on a null pointer: http://hg.mozilla.org/releases/mozilla-release/annotate/39faf812aaec/modules/libjar/nsJAR.cpp#l453

This was changed from a null-safe function (PL_strlen) to strlen in bug 800220, which apparently was in FF23.

Makoto, can you take this?
Assignee: nobody → m_kato
Blocks: 800220
Attached patch FixSplinter Review
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8350466 - Flags: review?(benjamin)
Attachment #8350466 - Flags: review?(benjamin) → review+
could you advise a workaround: probably, extension HebrewCalendar can be changed to avoid the crash?
This appears to be an issue with the .xpi signing. You could try not signing it, or somehow signing it differently. I really don't know exactly why this pointer is null.
What do you mean ".xpi signing"? I don't sign the extension with certificate.
(In reply to Igor from comment #4)
> could you advise a workaround: probably, extension HebrewCalendar can be
> changed to avoid the crash?

modify META-INF/MANIFEST.MF.  You can fix by adding CRLF to last line.
Crash Signature: [@ strlen | nsJAR::ReadLine(char const**)]
thank you!
workaround (modify META-INF/MANIFEST.MF.  You can fix by adding CRLF to last line.) works!
https://hg.mozilla.org/mozilla-central/rev/04052f81fa68
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Duplicate of this bug: 952932
You need to log in before you can comment on or make changes to this bug.