drag & drop no longer working

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: drstrust, Unassigned)

Tracking

28 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131216183647

Steps to reproduce:

Earlybird v28.0a2 (aurora)
Windows 7 Pro x64

A.
1. Open via Write a compose window
2. Click cursor in the compose pane
3. Go to browser (e.g. Firefox) and highlight select desired text/image/etc
4. Drag it into the compose field, success indicated by a change in cursor.
5. Drop it.

B.
1. Click & highlight a section of text typed or pasted in a composition window
2. Click and hold the mouse button to move/drag & drop the text to another place in the msg
3. Observe the selected text move with the mouse/cursor
4. Release the mouse button



Actual results:

A.
Text/etc doesn't appear in the compose msg like it used to.  The window remains blank and the cursor remains where it was, e.g. at the top --but it freezes/no longer blinks.

B.
Text doesn't move (aka drag & drop) and instead remains in the original location.  The cursor either freezes in place or in some instances disappears.  You can move the insert point and type characters there, but the cursor/indicator isn't there.


Expected results:

A.
The copied info should have appeared in the compose msg as it is in the browser window.  Along with the cursor moving to the end of the dropped text.
And as in fact it does when I return to the browser page and do a "Copy" of the same text, then go to the same Compose msg and click "Paste" and it appears normally (identical to how it appears on the webpage, and as it used to in Earlybird prior to bug).

It also fails with just a highlighted>drag & drop image (jpg/gif/etc), which also used to work.  This fails from a browser page, but also from a Windows file source e.g. Explorer/Search.
Also, after an attempted drag & drop, the cursor stops blinking/freezes as well.  
This also happens if I do a select text highlight and try to move it to another spot in the text.  But in most cases the cursor disappears all together.  You can however type new text, just with no visible cursor indication (thus guesstimating where the text will appear).

This has been a bug for several of the latest daily aurora channel updates.
Results are the same with all add-ons disabled via "Restart with Add-ons disabled" option.

thanks~

Comment 1

5 years ago
Maybe dup of bug 948839
(Reporter)

Comment 2

5 years ago
Regarding possible dup, just to be sure: a.) my experience is with Earlybird >Writer rather than Firefox, and b.) even though it happens when dragging from Firefox (window/tab), it also happens when dragging from Windows Explorer and Agent Ransack (file search) windows (where it used to also work for me from).  ~thanks
(Reporter)

Comment 3

5 years ago
* update *
It seems the image drag&drop is working again--however, the issue with the subsequent disappearing cursor is still around:

1. Open a Write window
2. Drag & drop an image
3. The image now drops, but the cursor disappears from view.
3a. In addition, this same problem happens when you use the Insert> Image and Insert> Table toolbar features.
The cursor is there, confirmed via typing, where the characters appear but the cursor is just not viewable.
3b. Also, the ability to use the keyboard arrow, end, home keys to move the cursor becomes disabled/does nothing.  Though it's not visible, i can at least place the cursor with the mouse and it plants there, whereas with the other keys nothing changes.

*note: a mouse click away from the Write window (to another desktop window) restores the cursor as visible/functional.

This has been a ongoing issue for at least the last 8-10 Earlybird daily updates (probably since the drag&drop aspect was fixed?).

~thanks

Comment 4

4 years ago
Does it happen with Thunderbird started in *Windows'* safe mode with networking enabled?
- win7 http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode
Flags: needinfo?(drstrust)

Comment 5

4 years ago
Sorry, wrong link above.

Does it happen with thunderbird started in safe mode?
- http://support.mozillamessaging.com/en-US/kb/safe-mode

Comment 6

4 years ago
WFM per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(drstrust)
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

4 years ago
#apologies --never got around to testing via safe mode...but:

WFM now as well!  Thanks Wayne etal~
(Reporter)

Comment 8

4 years ago
ETLP:  Earlybird v32.0a2 (2014-07-04)
You need to log in before you can comment on or make changes to this bug.