[OTA] Cannot upgrade Buri device to latest 1.2 Nightly build

RESOLVED DUPLICATE of bug 935059

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 935059
5 years ago
5 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I have an Alcatel One Touch Fire with a Nightly build from 20131209 installed. After checking for updates and downloading it the process always gets stopped after unpacking. The update process is in a loop and doesn't let me cancel the update or continue. So I'm currently stuck. The message I got via ADB is:

I/GeckoUpdater( 2181): Finished applying update
I/GonkAutoMounter( 2181): Mounted /system partition as read-only
I/Gecko   (  279): *** AUS:SVC readStatusFile - status: failed: 7, path: /data/local/updates/0/update.status
E/GeckoConsole(  279): AUS:SVC readStatusFile - status: failed: 7, path: /data/local/updates/0/update.status
I/Gecko   (  279): UpdatePrompt: Update error, state: failed, errorCode: 7
I/Gecko   (  279): UpdatePrompt: Setting gecko.updateStatus: Install Pending
I/Gecko   (  279): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 7
E/GeckoConsole(  279): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 7

Sadly right after the phone went to sleep and the connection got disconnected due to bug 915974. Now I'm not able to get the phone reconnected via USB to read out the update.status file.

Dave, do you have an idea what's going on here?
Flags: needinfo?(dhylands)
I can answer this.

OTAs won't work correctly on Buri devices right now because we run out of space when trying to apply the update, as the update files are too large to be temporarily stored during the update. The solution here is to move to a FOTA solution, which is being worked on in bug 935059.

For testing this on Buri for now, you'll need to rely on flashing a build directly to keep your build up to date. Only leo can use the OTA update solution, as leo has enough space to support the storage requirements of the update files used during the OTA update workflow.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dhylands)
Resolution: --- → DUPLICATE
Duplicate of bug: 935059
You need to log in before you can comment on or make changes to this bug.