Closed Bug 952235 Opened 6 years ago Closed 6 years ago

SVG is broken

Categories

(Core :: SVG, defect)

27 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla29
Tracking Status
firefox26 --- unaffected
firefox27 + verified
firefox28 + verified
firefox29 + verified
b2g-v1.3 --- fixed

People

(Reporter: alice0775, Assigned: mattwoodrow, NeedInfo)

References

Details

(Keywords: regression, Whiteboard: [bugday-20140108])

Attachments

(3 files)

Attached image ask_logo.svg
Steps to Reproduce:
1. Open attached

Actual Results:
SVG is broken


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/530f65e0bec5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131107113649
Bad:
http://hg.mozilla.org/mozilla-central/rev/545887140a1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131107114543
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=530f65e0bec5&tochange=545887140a1b

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f48aa69ea925
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131107005910
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/72784fe5e836
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131107015109
Pushlog:
http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/

Suspected : Bug 934674
FYI,
Setting gfx.content.azure.enabled = false helps in Firefox27b2
Assignee: nobody → matt.woodrow
I can reproduce in Nightly on Ubuntu 13.10. --> Setting Platform to All/All.
OS: Windows 7 → All
Hardware: x86_64 → All
Attachment #8350419 - Flags: review?(bas) → review+
Duplicate of this bug: 953085
Matt, can you land this on trunk as soon as you get a chance? Or if it's ready to get, let me know and I'll land it. I'd like to get some bake time before requesting approval to land on aurora and beta.
@Matt on holiday until 20 Jan....
Flags: needinfo?(birtles)
Flags: needinfo?(bas)
(In reply to Alice0775 White from comment #7)
> @Matt on holiday until 20 Jan....

Thanks Alice. I've pushed to try (accidentally got a few extra changesets from m-i in there but oh well):

https://tbpl.mozilla.org/?tree=Try&rev=b81a30cf0b06

If all looks ok I'll go ahead and push it to m-i tomorrow.
Flags: needinfo?(birtles)
Flags: needinfo?(bas)
(In reply to Brian Birtles (:birtles) from comment #8)
> If all looks ok I'll go ahead and push it to m-i tomorrow.

Try run looks ok.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e21f81181a41

This still needs a test case.
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/e21f81181a41
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Fix works for me on Firefox Nightly 29, Linux x86_64

[bugday-20120108]
sorry, 

*[bugday-20140108]
NI on :mattwoodrow to see if this is low risk enough to uplift for tomorrow's beta or do you recommend this to get more baketime on nightly/aurora before we uplift ?
Flags: needinfo?(matt.woodrow)
(In reply to bhavana bajaj [:bajaj] from comment #13)
> NI on :mattwoodrow to see if this is low risk enough to uplift for
> tomorrow's beta or do you recommend this to get more baketime on
> nightly/aurora before we uplift ?

Matt's on leave until the 20th. Bas, do you think this is safe for uplift?
Flags: needinfo?(matt.woodrow) → needinfo?(bas)
(In reply to Brian Birtles (:birtles) from comment #14)
> (In reply to bhavana bajaj [:bajaj] from comment #13)
> > NI on :mattwoodrow to see if this is low risk enough to uplift for
> > tomorrow's beta or do you recommend this to get more baketime on
> > nightly/aurora before we uplift ?
> 
> Matt's on leave until the 20th. Bas, do you think this is safe for uplift?

Absolutely.
Flags: needinfo?(bas)
Comment on attachment 8350419 [details] [diff] [review]
Handle the device offset at this end too.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 934674
User impact if declined: Various SVG files are rendered incorrectly.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): minor. Possibility that rendering is corrupted elsewhere?
String or IDL/UUID changes made by this patch: none
Attachment #8350419 - Flags: approval-mozilla-beta?
Attachment #8350419 - Flags: approval-mozilla-aurora?
Attachment #8350419 - Flags: approval-mozilla-beta?
Attachment #8350419 - Flags: approval-mozilla-beta+
Attachment #8350419 - Flags: approval-mozilla-aurora?
Attachment #8350419 - Flags: approval-mozilla-aurora+
I won't be able to land this for at least 12 hours. Not sure how important it is to get this in the next beta but if anyone else wants to land it, please go ahead.
Verified as fixed on Firefox 27 beta 5 and the 01/09 Firefox 29.0a1 - Windows 7 64bit, Mac OS X 10.8.5, Ubuntu 13.04 32bit.

The bug still reproduces on the 01/09 Firefox 28.0a2 on Windows and Ubuntu, but it seems fixed on the 01/10 Mac build. I suppose the fix didn't get into the 01/09 Aurora, so I'll retest this next week.
Status: RESOLVED → VERIFIED
Verified as fixed on the 01/13 Firefox 28.0a2 (Ubuntu 13.04 32bit and Mac OS X 10.8.5) and on the 01/12 Firefox 28.0a2 (Window 7 64bit).
Whiteboard: [bugday-20140108]
Hi Matt, any chance you could make up a regression test for this?
Flags: needinfo?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.