[Intermittent] Cannot communicate in an audio P2P call in Desktop Firefox in a B2G --> Desktop call on the same wifi network

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: slee)

Tracking

29 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Reporter)

Description

5 years ago
Build - 12/19/2013 Leo 1.4

STR

1. Go to http://mysecondwebrtc.appspot.com/ on Desktop Firefox Beta (Gecko 27) on low activity wifi network
2. Go to http://mysecondwebrtc.appspot.com/ on FxOS 1.4 (Gecko 29) on same wifi network as [1]
3. Request access & grant access to your mic on Desktop Firefox & FxOS
4. Register the remote client ID on FxOS
5. Try talking into the mic on Desktop

Expected

The sound should be heard on FxOS.

Actual

No sound is heard on FxOS.

Additional Notes

The sound is heard fine from FxOS to Desktop. So it looks like audio communication is working in one direction, but failing in the other direction.
(Reporter)

Updated

5 years ago
Blocks: 945256, 750011
Tried with fresh B2G head + inbound (29) on a Peak to recent inbound on linux.  Audio works both ways (though it's a pain you can't mute the local video element on B2G - you might put a button to mute it).

Can you retry, and if it continues to not work get logs from both sides?  I'm sure it's easiest to get the logs from a debug build on desktop.
Flags: needinfo?(jsmith)
(Reporter)

Comment 2

5 years ago
I'll take another look - it could be a weird issue with my leo build setup. I'll retest on Buri.

FWIW - I did get an audio P2P call working in both directions when communicating from a Buri 1.4 build to a FxAndroid Nightly 29 build.
Flags: needinfo?(jsmith)
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Comment 3

5 years ago
Okay - must have been weird issue on my desktop machine. I got it working with the latest gaia/gecko on trunk both directions for 3 minutes straight.
No longer blocks: 750011, 945256
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
Turns out Nikolai hit the same problem over in https://bugzilla.mozilla.org/show_bug.cgi?id=962338#c8, so sounds like there's a real bug here, not a hardware problem.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
(Reporter)

Comment 5

5 years ago
I'm putting qawanted for myself to work with Nikolai to get some logs with this bug.
Keywords: qawanted
(Reporter)

Comment 6

5 years ago
Clarifying in title that this is intermittent, as the tester who investigated this clarified that the reproduction rate was 40%.

When this does happen however, the issue in comment 0 happens exactly as described.
Summary: Cannot communicate in an audio P2P call in Desktop Firefox in a B2G --> Desktop call on the same wifi network → [Intermittent] Cannot communicate in an audio P2P call in Desktop Firefox in a B2G --> Desktop call on the same wifi network
1.3+ for lack of audio between peers.

CJ,

Please help review and reassign
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(cku)

Updated

5 years ago
Assignee: nobody → slee
Flags: needinfo?(cku)
(Reporter)

Comment 8

5 years ago
Discussed with Nikolai offline what to do here - he's getting signaling logs for this bug.
QA Contact: jsmith → nkhristoforov
(Reporter)

Comment 9

5 years ago
Nikolai looked into this, but can no longer reproduce again. We'll keep an eye out for this going forward though.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.