Closed Bug 952305 Opened 6 years ago Closed 6 years ago

[Gaia][Systems] 'net_error' page should handle errors other than 'netOffline' and 'dnsNotFound' gracefully

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 verified)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- verified

People

(Reporter: aus, Assigned: aus)

References

Details

(Keywords: regression, Whiteboard: [systemsfe][p=5])

Attachments

(3 files)

Right now our net_error page deals with netOffline and dnsNotFound errors. It does *not* handle other errors very well though. We default to netOffline.

There is a default error message that is included in the URI that is used to invoke us. It comes from gecko and should generally be sensible. The only problem is branding. Often, these strings will have 'Firefox' as the product name.

We need to discuss with UX. It may be best to have our own error messages for all errors as well as a generic default specific to FxOS.
Flags: needinfo?(fdjabri)
Depends on: 949286
At the minimum, we have to resolve the default fallback error page to show the generic error page. Therefore, we should focus this scope of this bug ensuring that the error pages 1.2 and earlier on continue to work.

Noming to block for getting parity with 1.2 again with the new error page setup.
Component: Gaia::System → Gaia::System::Window Mgmt
Whiteboard: [systemsfe]
Blocks: 882186
blocking-b2g: --- → 1.3?
I think it's more likely that the functionality that was present in 1.2 wrt error pages is more likely to change with this discussion (and following work) than revert to what it was before. I mean, we did work to replace this page for a reason and it's not to go back to displaying the old stuff. :) 

I believe that, visually, we're there already. Now it's about messaging for the default case (and potentially other known cases for which we do not have specific messaging).
FWIW - here's my old notes when I tested app errors in 1.01

https://etherpad.mozilla.org/app-errors-testing
How does net error page related to window management?
Component: Gaia::System::Window Mgmt → Gaia::System
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #4)
> How does net error page related to window management?

Error pages are part of window management. This was already discussed offline about the scope of that component. It's also in the component description.
Component: Gaia::System → Gaia::System::Window Mgmt
Whiteboard: [systemsfe] → [systemsfe][p=5]
Hi Aus,

Is this a dup of bug 912445?
Flags: needinfo?(aus)
(In reply to Michael Henretty [:mhenretty] from comment #6)
> Hi Aus,
> 
> Is this a dup of bug 912445?

Nope. This is different - this has to do with handling the other various error codes that propagate to the net error page and how we handle them. Right now, we only handle two error codes & fallback to the offline error on all other cases, which isn't right. We need to know what error codes we need to handle in 1.3 timeframe along with the fallback error page.
To clarify - this bug is focusing on what regressed here from 1.2 app errors wise, not new feature work.
Keywords: regression
blocking-b2g: 1.3? → 1.3+
I'll be using the stock error message from gecko for all errors other than netOffline and dnsNotFound for 1.3, this is what will also land for 1.4 until we decide to go with specific error messages for other network errors.
Flags: needinfo?(aus)
Flags: needinfo?(fdjabri)
Comment on attachment 8356861 [details] [review]
Pull Request - Use gecko default error message for errors with no special casing.

Added some comments on the PR.
PR updated. Should be ready to land now.
Comment on attachment 8356861 [details] [review]
Pull Request - Use gecko default error message for errors with no special casing.

Code looks good!

Still need UX sign-off from Francis, especially for the iframe case since the spec (https://bug942325.bugzilla.mozilla.org/attachment.cgi?id=8339620, page 10) doesn't cover this case.
Attachment #8356861 - Flags: review?(mhenretty) → review+
Attachment #8356856 - Flags: feedback?(fdjabri) → feedback+
Attachment #8357398 - Flags: feedback?(fdjabri) → feedback+
Fixed on master.

Commit: https://github.com/mozilla-b2g/gaia/commit/5fb2937233c670f311725e62a81fb88b487406ff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Uplifted 5fb2937233c670f311725e62a81fb88b487406ff to:
v1.3: afe98bd0347f31612f9b86868fc5adad504a6570
Duplicate of this bug: 943261
Concept of the patch works, although during other landings post this patch, I've noticed a fallout that's occurred for this bug in bug 963322.
You need to log in before you can comment on or make changes to this bug.