Credit Card payments are not supported in Hanger

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rafael.medola, Assigned: Tom)

Tracking

Other
Gonk (Firefox OS)
Points:
---
Bug Flags:
affects-hanger +

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
Created attachment 8350627 [details]
ezboot-http-10-70.log

Region code: Hanger
Device: Alcatel
Connection: 3G
Phone number/MSISDN: +37203747379
Carrier: Telenor
Last 4 digits CC: 7929
Test App used: pricetier 10-120

steps to reproduce:

1- Login to the Markeplace;
2- Set the region to Hungary;
3- Search for pricetiers;
4- try to buy using CC tiers 10-120;

expected behavior:

In Hanger tiers 10-70 carrier billing and CC option are available and the user can buy normally using the cc option.
In Hanger tiers 80-120 just cc billing is available and the user can buy normally using cc.

observed behavior:

In Hanger tiers 10-70 carrier billing and CC option is missing.
In Hanger tiers 80-120 just cc billing is available and a Not Support payment method screen appears clicking to buy.
(Reporter)

Comment 1

4 years ago
Created attachment 8350628 [details]
cc_option_missing-10-70
(Reporter)

Comment 2

4 years ago
Created attachment 8350629 [details]
2013-12-20-16-07-20.png
(Reporter)

Comment 3

4 years ago
Created attachment 8350630 [details]
ezboot-http80-120.log
(Reporter)

Comment 4

4 years ago
Created attachment 8350631 [details]
80-120
(Reporter)

Comment 5

4 years ago
Created attachment 8350632 [details]
2013-12-20-16-06-22.png

Updated

4 years ago
Assignee: nobody → tom

Updated

4 years ago
Flags: affects-hanger+
(Assignee)

Comment 6

4 years ago
You created a new user which then received a Country Mismatch error because you were using a Brazilian credit card. I have added CP status to this new user and removed payment bars. This will be fixed now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.