fix failing units tests caused by jsdom

RESOLVED FIXED

Status

Webmaker
Thimble
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pomax, Assigned: pomax)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The jsdom package is causing slowparse failures on SVG and (implicitly) self-closing elements. They're known-fails for now, but they should become passes, so this probably requires using not-jsdom or a headless browser.
(Assignee)

Updated

4 years ago
Assignee: nobody → pomax
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Failing tests caused by bugs/incompletions in jsdom.
ref: https://github.com/tmpvar/jsdom/issues/705
ref: https://github.com/tmpvar/jsdom/issues/706
(Assignee)

Comment 2

4 years ago
Created attachment 8350863 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/336

and now all unit tests pass.
Attachment #8350863 - Flags: review?(ali)
Attachment #8350863 - Flags: review?(ali) → review+

Comment 3

4 years ago
Commit pushed to master at https://github.com/mozilla/thimble.webmaker.org

https://github.com/mozilla/thimble.webmaker.org/commit/0b2bd015d5336144dfd7ae29c131230aacf23236
Merge pull request #336 from Pomax/bug952509

fix + jsdom deferral
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.