TB 27b1: Recipient autocomplete dropdown shows blank contacts (icon-only, no names and email addresses) - caused by MoreFunctionsForAddressBook addon

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: jlerner10, Unassigned)

Tracking

27 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:MoreFunctionsForAddressBook])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8350652 [details]
TB 27b1.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131216183647

Steps to reproduce:

When writing an email and you enter the first few letters there should be list of potential contacts.
This list or drop down is missing those that come after the first name.

Also posted this on Mozillazine to see if anyone else has this problem and a possible fix.
http://forums.mozillazine.org/viewtopic.php?f=29&t=2785559

Same thing happened on my laptop.

On laptop - Removed TB 27 and reinstalled TB 26 and everything is back to normal.


Actual results:

Only the first name shows up


Expected results:

All names that begin or have the first letter or letters should be visible
Josia, could this be a theme issue? Any insights how this could happen?
Component: Untriaged → Message Compose Window
Flags: needinfo?(josiah)
Summary: Writing email - Missing Contacts - TB 27b1 → TB 27b1: Recipient autocomplete dropdown shows blank contacts (icon-only, no names and email addresses; screen update or font color problem?)
In MozillaZine you wrote it doesn't happen in safe mode. Please can you disable all extensions and enable one and check if the problem appears. If not, enable the next extension until this happens. Then hopefully we can find which add-on causes this problem.
Flags: needinfo?(jlerner10)
(Reporter)

Comment 3

4 years ago
I believe I found the problem.
As you suggested I disabled my add-ons one at a time.
Luckily I only have or had 2, Lightning and MoreFunctionsForAddressBook.

It seems that MoreFunctionsForAddressBook is or was the problem. A soon as I disabled it I was able to see and pick the names in the drop down.

I should have realized this before I posted here.
I will try to contact them to let them know it does not work in TB 27.

Thanks for your help.
Flags: needinfo?(jlerner10)
(In reply to Richard Marti (:Paenglab) from comment #2)
> In MozillaZine you wrote it doesn't happen in safe mode. Please can you
> disable all extensions and enable one and check if the problem appears. If
> not, enable the next extension until this happens. Then hopefully we can
> find which add-on causes this problem.

Awesome cooperation, thanks Richard & jlerner for figuring this out.

Jlerner, when you contact addon authors, can you please let them know about the following bugs where there's recent work being done or planned on autocomplete:

https://bugzilla.mozilla.org/show_bug.cgi?id=529584 (fixed - temporary new autocomplete search algorithm: *foo bar*)
https://bugzilla.mozilla.org/show_bug.cgi?id=558931 (patch pending - new autocomplete search algorithm: *foo* & *bar*)
https://bugzilla.mozilla.org/show_bug.cgi?id=298438 (under discussion; applicable to autocomplete, too - search more or all AB fields)
https://bugzilla.mozilla.org/show_bug.cgi?id=556490 (future: unify search ab and autocomplete search queries as far as possible and make them more customizable via template prefs)

Can you please report back here if you managed to contact them and if there's a ticket number for their bug where it is tracked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(josiah) → needinfo?(jlerner10)
Resolution: --- → INVALID
Summary: TB 27b1: Recipient autocomplete dropdown shows blank contacts (icon-only, no names and email addresses; screen update or font color problem?) → TB 27b1: Recipient autocomplete dropdown shows blank contacts (icon-only, no names and email addresses) - caused by MoreFunctionsForAddressBook addon
Whiteboard: [addon bug]
(Reporter)

Comment 5

4 years ago
Sent an email about this problem plus the links for this problem.
I hope I get a response.

If I do get one I'll report back.
Flags: needinfo?(jlerner10)
(Reporter)

Comment 6

4 years ago
I heard back from the programmer for this add on and he said "thanks for the report, it will be fixed in the next update."

I replied back to ask how soon. Waiting for answer.
(Reporter)

Comment 7

4 years ago
Just a follow up again.

Got the following from the programmer of MoreFunctionsForAddressBook.

He said "The new version is ready, but I've to wait the update from the
translators, since it has some new strings. Probably I  will release it in
the first week of the new year."
(In reply to jlerner10 from comment #7)
> Just a follow up again.

jlerner, thank you for the followup info, that's helpful! :)
(Reporter)

Comment 9

4 years ago
The update for MoreFunctionsForAddressBook was just downloaded and it corrected this problem.

Updated

4 years ago
Whiteboard: [addon bug] → [addon:MoreFunctionsForAddressBook]
You need to log in before you can comment on or make changes to this bug.