Closed Bug 952521 Opened 6 years ago Closed 6 years ago

Touch events generated with marionette change target depending on the window position on b2g desktop

Categories

(Testing :: Marionette, defect, major)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 891882

People

(Reporter: etienne, Unassigned)

Details

(Whiteboard: [u=marionette-user c=marionette-server p=2])

Attachments

(3 files)

The marionette JS keypad test [1] which works perfectly on travis is perma red on a mac.

The test uses marionette's press/release commands to generate touch events and type "123" in the dialer.
Running the test on a mac you get "456" instead.

Digging a bit we realized that moving the window to the left made the test type only "56" then "6" even further.

Vivien says it's probably a case of using screenX/screenY instead of clientX/clientY.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/test/marionette/keypad_test.js
Summary: Touch events generated with marionette change target depending on the window position → Touch events generated with marionette change target depending on the window position on b2g desktop
Attached image window to the left
Moving to major priority since this discrepancy can lead to more tests failing.
Severity: normal → major
Whiteboard: [u=marionette-user c=marionette-server p=2]
Looks this got fixed as part of bug 891882 :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891882
You need to log in before you can comment on or make changes to this bug.