[B2G] Cannot pick a .zip file

RESOLVED DUPLICATE of bug 945952

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 945952
5 years ago
5 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
* Open a page with a <input type="file">, e.g. http://dl.free.fr
* Pick a .zip file using either Explorer (https://marketplace.firefox.com/app/explorer?src=search) or Alpha Explorer (https://marketplace.firefox.com/app/alpha-explorer?src=search), the two only file pickers I could find.
* For the user, nothing happens.

Logs:
E/GeckoConsole( 1426): [JavaScript Error: "NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIMIMEService.getFromTypeAndExtension]" {file: "jar:file:///system/b2g/omni.ja!/components/FilePicker.js" line: 166}]

Note that I have no problem when I pick a .png, so this is most likely extension/mimetype-related.

As a side-note, this makes my FirefoxOS comic book reader completely useless :/
I forgot to add that this is Firefox OS 1.1 on Unagi. Since this is a Unagi, I cannot upgrade to more recent versions.
OS: All → Gonk (Firefox OS)
Incidentally, why are we passing '' as second argument instead of an extension to getFromTypeAndExtension?

Comment 3

5 years ago
That problem was fixed with https://bugzilla.mozilla.org/show_bug.cgi?id=920905 and https://bugzilla.mozilla.org/show_bug.cgi?id=945952, but only in version >= 1.3.
Good news, I guess. Too bad for me I can't upgrade :/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945952
You need to log in before you can comment on or make changes to this bug.