[B2G][Web Audio] Using the ScriptProcessorNode does not behave as expected

RESOLVED WONTFIX

Status

()

Core
Web Audio
P2
normal
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: PBylenga, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v1.2 affected, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 affected)

Details

(Whiteboard: permafail)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8350711 [details]
ScriptProcessorNodeWebAudio_log.txt

Description:
ScriptProcessorNode does not start playing sound on first few attempts of tapping [Play/Pause] dialog button.  Also when it does initiate playback, the stream has stuttering’s and gaps.

Repro Steps:
1) Update Buri to Build ID: 20131219004002
2) Launch Browser App and navigate to http://zapion.github.io/webaudio/install.html
3) Install test app by tapping on dialog button
4) Navigate to Homescreen and launch WebAudio Test App
5) Select “Script-processor” option
6) Tap [Play/Pause] button and observe playback quality.

Actual:
Playback is not first initiated and playback has stuttering’s and gaps when it does play.

Expected:
Playback is initiated on first attempt and streaming quality is smooth.

Environmental Variables
Device: Buri v1.3 COM RIL
Build ID: 20131219004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/809aabadac6d
Gaia: a99249a7fdf9f20850d98a9a222385676d472362
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: 20131115

Notes:
Repro frequency: 5/5, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9992/
See attached: logcat


This issue reproduces on v1.2 similarly

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131218004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/dcffefec8206
Gaia: 38338b31b554cdb8c6242b15a966f171a0e7abaa
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: 20131115

Updated

5 years ago
Whiteboard: burirun1.3-1 → burirun1.3-1, buri1.3-2
Peter -- Can you retest with the latest 1.4 (nightly) build?  Thanks.
Flags: needinfo?(pbylenga)
Priority: -- → P2
(Reporter)

Comment 2

4 years ago
I retested this and it's definitely improved.  I still detect two small pauses though, I'd estimate about a 1/16th note in size.  One near the beginning and one midway.

Master v1.4 Environmental Variables:
Device: Buri Master v1.4 MOZ
BuildID: 20140203040201
Gaia: 3b2fe2f86164f95db699b6ea2661925b21ecb994
Gecko: 44ba69cacd7e
Version: 29.0a1
Firmware Version: v1.2-device.cfg
Flags: needinfo?(pbylenga)
status-b2g-v1.4: --- → affected
Whiteboard: burirun1.3-1, buri1.3-2 → burirun1.3-1, buri1.3-2, burirun1.4-1
Whiteboard: burirun1.3-1, buri1.3-2, burirun1.4-1 → permafail

Updated

4 years ago
status-b2g-v1.3T: --- → affected
This is expected, and is the reason we are doing the AudioWorkerNode, I'm closing this because we can't do much.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.