[B2G][Contact]Users cannot export their favorite contacts.

RESOLVED DUPLICATE of bug 944648

Status

defect
RESOLVED DUPLICATE of bug 944648
6 years ago
6 years ago

People

(Reporter: rkunkel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1.3-1)

Attachments

(1 attachment)

Reporter

Description

6 years ago
Posted file logcat
Description:
Users cannot export their favorite contacts to their SIM card. 
Regular contacts can be exported as expected.

Repro Steps:
1) Update Buri to v1.3 BuildID: 20131220004001
2) Favorite a contact.
3) Contacts > Settings > Export > SIM card

Actual:
User is unable to export their favorite contact(s)

Expected:
User is able to export their favorite contact(s)

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131220004001
Gaia: ee5560ab86103701a5d046ef31d46e6c1e026355
Gecko: 40c4cb09bce5
Version: 28.0a2
Firmware Version: 

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9894/
See attached: logcat
Does this reproduce on 1.2?
Keywords: qawanted

Comment 2

6 years ago
This does not repro on latest 1.3 or 1.2. Checked after exporting by unfavoriting and deleting contact then importing from SIM to see if it worked properly.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131223004001
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Gecko: af28fe58e263
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: 20131115

Environmental Variables:
Device: Buri 1.2 mozRIL
BuildID: 20131223004001
Gaia: 724d36716bcbbc5cee1af18b94cc328c289d0ccc
Gecko: 931864adcf68
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: qawanted
Ronald - Can you double check your STR here to see if there's step missing to reproduce this?
Flags: needinfo?(rkunkel)
Reporter

Comment 4

6 years ago
(In reply to Jason Smith [:jsmith] from comment #3)
> Ronald - Can you double check your STR here to see if there's step missing
> to reproduce this?

Testing this on the latest Buri v1.3 build.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140102004001
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Gecko: 61f553e5db49
Version: 28.0a2
Firmware Version: 20131115

1) On this build I was able to reproduce the issue on my device. 

2) Working with Garrett from comment #3, we were unable to reproduce the issue on his phone.

3) After replacing the SIM card in my device, I was unable to reproduce the issue.
(In reply to Roland Kunkel [:RolandK] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > Ronald - Can you double check your STR here to see if there's step missing
> > to reproduce this?
> 
> Testing this on the latest Buri v1.3 build.
> 
> Environmental Variables:
> Device: Buri v1.3 Mozilla RIL
> BuildID: 20140102004001
> Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
> Gecko: 61f553e5db49
> Version: 28.0a2
> Firmware Version: 20131115
> 
> 1) On this build I was able to reproduce the issue on my device. 
> 
> 2) Working with Garrett from comment #3, we were unable to reproduce the
> issue on his phone.
> 
> 3) After replacing the SIM card in my device, I was unable to reproduce the
> issue.

Can you provide more information about the SIM card that's reproducing the bug? How many contacts are stored on it? What type of SIM is it?

My guess is that the SIM card is out of space to accept new contacts, which makes this a dupe of a known bug.
Reporter

Comment 6

6 years ago
(In reply to Jason Smith [:jsmith] from comment #5)

> Can you provide more information about the SIM card that's reproducing the
> bug? How many contacts are stored on it? What type of SIM is it?

It's an AT&T SIM Card and there are 250 contacts stored on it. 

> My guess is that the SIM card is out of space to accept new contacts, which
> makes this a dupe of a known bug.

Searched for the bug mentioned and found 250 contacts is the max number of contacts. Definitely a dupe of bug# 944648 :(
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 944648
Flags: needinfo?(rkunkel)
You need to log in before you can comment on or make changes to this bug.