[B2G][Email] Selecting an email notification does not open the email app while in another app

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Josh Schmitt [Joshs], Assigned: jrburke)

Tracking

({regression})

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-1)

(Reporter)

Description

5 years ago
Description:
Email notifications do not open the email app if the user is in any other app e.g. 'Gallery' 'Video'

Repro Steps:
1) Updated Buri to BuildID: 20131220004001
2) Open the email app
3) Setup an account with a 5 min sync time
4) Send an email to said account from a different email
5) Close the email app
6) Load any other app e.g. 'Gallery' 'Video' and wait 5 mins
7) Select the 'new' email notification

Actual:
Selecting the 'new' email notifications does not open the email app.

Expected:
The email app opens upon selection of the notifications.

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20131220004001
Gaia: ee5560ab86103701a5d046ef31d46e6c1e026355
Gecko: 40c4cb09bce5
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: v1.20131115
(Reporter)

Comment 1

5 years ago
Issue does not occur on Buri 1.2 COM

Environmental Variables:
Device: Buri 1.2 COM
BuildID: 20131218004002
Gaia: 38338b31b554cdb8c6242b15a966f171a0e7abaa
Gecko: dcffefec8206
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: v1.20131115

Updated

5 years ago
blocking-b2g: --- → 1.3?

Updated

5 years ago
QA Contact: gbennett

Comment 2

5 years ago
.:First Broken Build:.
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131017040202
Gaia: 616e87af0133496620aea89f21ca5d37acedf466
Gecko: 423b9c30c73d
Version: 27.0a1
RIL Version: 01.02.00.019.102
Firmware Version: 20131115

.:Last Working Build:.
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131016040202
Gaia: 3d4f1107e6e91e5f5649edc0f2565ac837111d7d
Gecko: 9f63bbc00527
Version: 27.0a1
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: regressionwindow-wanted
triage: blocking. need further investigation to figure out if this is an email issue or more of a systems issue
blocking-b2g: 1.3? → 1.3+

Updated

5 years ago
Duplicate of this bug: 957335
(Assignee)

Updated

5 years ago
Assignee: nobody → jrburke
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Assignee)

Comment 5

5 years ago
I am having trouble reproducing. Here is what I did:

* Grabbed a nightly pvt build, in directory: mozilla.org/b2g_ril/latest-hamachi-eng-mozilla-aurora/hamachi-eng-mozilla-aurora-latest.zip, dated 10-Jan-2014 10:47
* Switched to v1.3 branch in gaia repo and installed that.

When I look at more phone info:

OS version
1.3.0.0-prerelease

Hardware revision
qcom

Platform version
28.0a2

Build identifier
20140110004009

Update channel
hamachi/1.3.0/default

Git commit info
2014-01-10 17:33:22
1f029aa4

and I cannot reproduce. However, I am also a bit out of practice working on a branch build. Could I have links to the builds used to reproduce, and I can try those. Feel free to send the link to them privately if you wish.

Also, if you can reproduce, a logcat would be helpful. See https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo, the "A log of what was happening around the time the problem happened" section.

I also tried reproducing using the video from bug 957335 and it was not able to reproduce. That logcat indicated email had started up and was trying to show the email message_list card, so I'm not sure if it just needed a bit more time for another app to close/get memory cleared before it was shown or if it just was hiding in the background, or something else was wrong.
Flags: needinfo?(gbennett)

Updated

5 years ago
Keywords: qawanted

Comment 6

5 years ago
Interesting. It now works properly on the latest 1.3 (https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2g_ril/hamachi-mozilla-aurora-20140113004002-ril01.02.00.019.102.zip). You can find the builds from comment 2 within https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2g_ril/. Let me know if you need any more information, but this bug can no longer be reproduced.
Flags: needinfo?(gbennett)
(Assignee)

Comment 7

5 years ago
Perhaps there was some system notification changes in the interim. Going to close as worksforme as both QA and I cannot reproduce now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.