Closed Bug 952663 Opened 6 years ago Closed 6 years ago

Create tests for expected tab strip behavior

Categories

(Firefox for Metro Graveyard :: Tests, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(firefox28 fixed, firefox29 fixed)

RESOLVED FIXED
Firefox 29
Tracking Status
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

(Whiteboard: [beta28] [feature] p=1 [qa-])

Attachments

(1 file)

Create mochitests to verify the expected behavior of the tab strip in both precise (mouse) and imprecise (touch) input modes, wrt overflow handling and the scrollbuttons in particular.
Whiteboard: [triage]
Patch adds a couple of mochitests for handling the tab strip scrollbutton visibility in precise(mouse) and imprecise(touch) mode. A few of the assertions currently fail and are todo()s due to bug 952297. 

I needed the notifyImprecise function from the input tests so that's moved to head.js
Assignee: nobody → sfoster
Attachment #8355667 - Flags: review?(jmathies)
Point value estimate = 1
Comment on attachment 8355667 [details] [diff] [review]
mochitests for expected tab strip scrolling behavior

succeeds locally, code looks good.
Attachment #8355667 - Flags: review?(jmathies) → review+
Blocks: metrov1it22
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [triage] → [feature] p=1
Whiteboard: [feature] p=1 → [beta28] [feature] p=1
https://hg.mozilla.org/mozilla-central/rev/8b20a3f452a8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Blocks: 952297
Comment on attachment 8355667 [details] [diff] [review]
mochitests for expected tab strip scrolling behavior

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a

User impact if declined:  Test-only patch, no user impact.  Needed for clean uplift and testing of bug 952297.

Testing completed (on m-c, etc.):  On m-c since 01-06.

Risk to taking this patch (and alternatives if risky):  Low-risk, test-only.
 
String or IDL/UUID changes made by this patch:  None.
Attachment #8355667 - Flags: approval-mozilla-aurora?
Comment on attachment 8355667 [details] [diff] [review]
mochitests for expected tab strip scrolling behavior

for test-only fixes you can go ahead and land them with a=test-only
Attachment #8355667 - Flags: approval-mozilla-aurora?
Whiteboard: [beta28] [feature] p=1 → [beta28] [feature] p=1 [uplift note: depends on bug 952663]
Whiteboard: [beta28] [feature] p=1 [uplift note: depends on bug 952663] → [beta28] [feature] p=1
Whiteboard: [beta28] [feature] p=1 → [beta28] [feature] p=1 [qa-]
You need to log in before you can comment on or make changes to this bug.