[Facebook] [Contacts]Contacts import from FB fails after ~260 contacts

RESOLVED DUPLICATE of bug 950295

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 950295
4 years ago
4 years ago

People

(Reporter: John Hammink, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: burirun1.3-1, burirun1.3-2)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Gaia      44ef4351666899e583dc42a28f8f2c85c743acd1
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
BuildID   20131218004002
Version   28.0a2
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013

STR:  

Open the Contacts app.

Tap on the settings icon.(Gear Icon)

Toggle on Facebook.

Log in with a valid account.

Select 10/ 50/ 100/ 1000 Facebook contacts.  (I have 1444)

Run to check each set of Facebook contacts.

Press the Import button.

Expected result: All the contacts will be imported and will be displayed correctly.

Actual Result: Contact import stops at about 260
(Reporter)

Updated

4 years ago
No longer depends on: 859363
Whiteboard: burirun1.3-1
(Reporter)

Comment 1

4 years ago
Created attachment 8350835 [details]
fb.log - log of contacts app attempting to import 1444 contacts.  Stops here at 235.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.3?
QA Wanted - What happens on 1.2?
Keywords: qawanted

Updated

4 years ago
QA Contact: gbennett

Comment 3

4 years ago
No issue occurs on today's 1.3 or 1.2 using a FB account with 290 contacts. Leaving qawanted on as nobody here has an account with that many friends. 1.2's environmental variables below.

Build ID: 20131223004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/931864adcf68
Gaia: 724d36716bcbbc5cee1af18b94cc328c289d0ccc
Platform Version: 26.0
RIL Version: 01.02.00.019.102

Updated

4 years ago
QA Contact: gbennett

Updated

4 years ago
blocking-b2g: 1.3? → 1.3+
Component: Gaia::First Time Experience → Gaia::Contacts
Keywords: qawanted → regression
Created attachment 8358100 [details]
dmesg.txt

sigkilled due to OOM.  I had the same thing occur with 599 contacts.
Gaia      22bc6be5b76cdc6d4e9667ff070979041a20ce2f
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/2c8f8683bd0d
BuildID   20140109004002
Version   28.0a2
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013
This is a dup of bug 950295...

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950295
Whiteboard: burirun1.3-1 → burirun1.3-1, burirun1.3-2
You need to log in before you can comment on or make changes to this bug.