tab scrolling arrows have wrong activation state in Australis

RESOLVED DUPLICATE of bug 637608

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 637608
4 years ago
4 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8351178 [details]
Capture d'écran de 2013-12-23 12:46:16.png

1/ open a lot of tabs until the scrolling arrows appear on the right and left sides of the tab bar
2/ click on the activated arrow to scroll to next tab

expected result:
tab bar scrolls to the next tab

actual result:
nothing happens because there are no next tab, if you click on the deactivated arrow on the other side, you do get a tab scroll. The active/inactive status of the arrow is wrong, it should have an active style if there are tabs to scroll and an inactive style if there aren't. If you click multiple times on the inactive widget to scroll the tabs, when you arrive at the end of the tab bar, the buttons becomes active.

Tested on Linux/Gnome, I don't know if the bug happens in Windows/Mac

Updated

4 years ago
No longer blocks: 939862
OS: All → Linux
Whiteboard: dupeme

Comment 1

4 years ago
maybe duplication of Bug 637608

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 637608
You need to log in before you can comment on or make changes to this bug.