color swatch does not show when property has !important declaration

RESOLVED DUPLICATE of bug 947733

Status

RESOLVED DUPLICATE of bug 947733
5 years ago
4 months ago

People

(Reporter: terrychen1729, Unassigned)

Tracking

29 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8351237 [details]
Taken from the Get Firefox page (https://www.mozilla.org/en-US/firefox/new/)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Build ID: 20131223030203

Problem: When there is an !important declaration in a CSS property that accepts color values (e.g. color, background-color), the color swatch in the Style Inspector will not show.

Reproducible: Always

Steps to reproduce:
1. Go to any website
2. Inspect any element with a non-default color (where the default color is the color specified for that element in the UA's stylesheet)
3. Add !important to the property that defines the color of the element in the Style Inspector if the declaration does not already exist in said property

Actual results: The color swatch disappears.

Expected results: The color swatch should not disappear.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947733

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.