Closed Bug 952973 Opened 6 years ago Closed 6 years ago

Perform some content/base decom

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: dzbarsky, Assigned: dzbarsky)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

No description provided.
Attached patch PatchSplinter Review
Assignee: nobody → dzbarsky
Status: NEW → ASSIGNED
Attachment #8351247 - Flags: review?(bzbarsky)
Comment on attachment 8351247 [details] [diff] [review]
Patch

Review of attachment 8351247 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/base/src/nsCopySupport.cpp
@@ +508,5 @@
>  
>    NS_ENSURE_TRUE(document->IsHTML(), NS_OK);
>  
>    // init encoder with document and node
>    rv = docEncoder->Init(domDocument, NS_LITERAL_STRING(kHTMLMime),

NativeInit(document, ...)

@@ +514,5 @@
>                          nsIDocumentEncoder::OutputEncodeW3CEntities);
>    NS_ENSURE_SUCCESS(rv, rv);
>  
> +  nsCOMPtr<nsIDOMNode> node = do_QueryInterface(aDOMNode);
> +  rv = docEncoder->SetNode(node);

SetNativeNode(aDOMNode)
Comment on attachment 8351247 [details] [diff] [review]
Patch

r=me
Attachment #8351247 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/0946f6737699
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Whiteboard: [qa-]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.