[Bluetooth][Certification][PTS][BlueZ][1.3] HSP TC_AG_IAC_BV_01_I Failed

VERIFIED FIXED in Firefox 28

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: echang, Assigned: jaliu)

Tracking

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.3 fixed)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 8351320 [details]
TC_AG_IAC_BV_01_I.zip

### ENV
Buri/BlueZ
[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g26_v1_2-hamachi/2013/12/2013-12-17-00-40-01/

### STR
1. PTS 5.0
2. HSP TC_AG_IAC_BV_01_I

### Expected
Pass 

### Actual
est case : TC_AG_IAC_BV_01_I started
	- SDP Service record for PTS: 'Headset HS' successfully registered
	- AT: SPP connect succeeded
	- AT: RING
	- MTC: MTC: Call is connected
	- FATAL ERROR (MTC): Audio connection is expected, but not available.
	- AT: Service Level Connection disabled
	- MTC: Test case ended
Final Verdict : Fail
(Reporter)

Updated

5 years ago
Flags: needinfo?(jaliu)
(Reporter)

Updated

5 years ago
Summary: [Bluetooth][Certification][PTS][BlueZ] HSP TC_AG_IAC_BV_01_I Failed → [Bluetooth][Certification][PTS][BlueZ][1.3] HSP TC_AG_IAC_BV_01_I Failed
(Reporter)

Updated

5 years ago
Blocks: 951055
(Assignee)

Updated

5 years ago
Assignee: nobody → jaliu
Flags: needinfo?(jaliu)
(Assignee)

Comment 1

5 years ago
Created attachment 8357078 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP. (draft)
Attachment #8357078 - Flags: feedback?(echou)
Comment on attachment 8357078 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP. (draft)

Review of attachment 8357078 [details] [diff] [review]:
-----------------------------------------------------------------

I think the patch can fix the issue, however mHspConnected has to be renamed to a more reasonable name such as mIsHsp.
Attachment #8357078 - Flags: feedback?(echou) → feedback+
(Assignee)

Comment 3

5 years ago
Created attachment 8358140 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP.  (v1)
Attachment #8357078 - Attachment is obsolete: true
Attachment #8358140 - Flags: review?(echou)
Comment on attachment 8358140 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP.  (v1)

Review of attachment 8358140 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Jamin, please see my comments.

::: dom/bluetooth/bluez/BluetoothHfpManager.cpp
@@ +1647,5 @@
>      mHeadsetSocket->Disconnect();
>      mHeadsetSocket = nullptr;
>    } else if (aSocket == mHeadsetSocket) {
>      MOZ_ASSERT(!mSocket);
> +    mIsHsp = true;

Since mIsHsp is assigned to true here, how about also assigning mIsHsp to false in the block above which a HFP incoming connection is established?
(Assignee)

Comment 5

5 years ago
Created attachment 8358172 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP. (v2)
Attachment #8358140 - Attachment is obsolete: true
Attachment #8358140 - Flags: review?(echou)
Attachment #8358172 - Flags: review?(echou)
Comment on attachment 8358172 [details] [diff] [review]
[HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP. (v2)

Review of attachment 8358172 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thanks.
Attachment #8358172 - Flags: review?(echou) → review+
Certification blocker. Nominate as 1.3+.
blocking-b2g: --- → 1.3?
(Assignee)

Comment 8

5 years ago
Created attachment 8358295 [details] [diff] [review]
(final) [HSP] Set HSP flag when BluetoothHfpManager chooses to connect HSP. (v2)

It looks fine on try server.
https://tbpl.mozilla.org/?tree=Try&rev=3a364ba6170d
Attachment #8358172 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c42e826c8ed3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
blocking-b2g: 1.3? → 1.3+
https://hg.mozilla.org/releases/mozilla-aurora/rev/b6915bd4cb49
status-b2g-v1.3: --- → fixed
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
status-firefox29: --- → fixed
Duplicate of this bug: 953042
Duplicate of this bug: 953040
Duplicate of this bug: 953039
(Reporter)

Comment 15

5 years ago
Okay with latest v1.3

   │ Gaia      47049555282a9a01fb60d1e1421b57e2810c96f5                           │  
   │ Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c     │  
   │ BuildID   20140121004137                                                     │  
   │ Version   28.0a2                                                             │  
   │ ro.build.version.incremental=eng.archermind.20131114.105818                  │  
   │ ro.build.date=Thu Nov 14 10:58:33 CST 2013
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.