100% CPU Load, no JS, CSS only. Bootstrap 3.0.3. Probably faulty page rendering engine

RESOLVED WORKSFORME

Status

()

defect
--
major
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: gnatko, Unassigned)

Tracking

({perf, power, regression})

19 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 affected, firefox27 affected, firefox28 affected, firefox29 affected, firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox-esr17 unaffected, firefox-esr24 affected, firefox-esr31 affected)

Details

(Whiteboard: [Power])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Please open this URL:

http://m-marketing.ru/test-issue/

-- note that the CPU load is very high (on my 8-core Intel i7 I get 20%, people on systems with single-core CPU's get their CPU fans revving up to max)

Then open this URL:

http://m-marketing.ru/test-noissue/

-- In this case, the CPU load is 0%.

(Both pages are a copy of our front page -- http://m-marketing.ru/, with all JS stripped. On the main page, we also get a high CPU load)


Actual results:

Whenever you put any text inside the DIV with class "ib mm-white-spot mm-pbtm" - you get the CPU loading problem.

No JavaScript on this page.

Also, if I disable the "bootstrap.min.css" file, the CPU load also drops to 0%.

In Chrome, it's always 0%.


Expected results:

CPU load should be 0%. The page has no JavaScript, no animations.

I think the page rendering engine falls into an infinite loop for some reason. Serious debugging of the page rendering engine is needed.

Comment 1

5 years ago
On my end, it uses 45%, which means there's something off-main-thread running (one core uses 25%).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
If set image.high_quality_downscaling.enabled = false , the problem does not happen.

Regressio window(m-i) force image.high_quality_downscaling.enabled = true
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/eda2891c545b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928090936
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/92530b29ac24
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928100437
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eda2891c545b&tochange=92530b29ac24

Regressed by Bug 486918
Blocks: 486918
Severity: normal → major
Component: Untriaged → ImageLib
Keywords: perf, regression
Product: Firefox → Core
Version: 26 Branch → 19 Branch

Updated

5 years ago
Keywords: power
(Reporter)

Updated

5 years ago
Depends on: 846315
(Reporter)

Comment 3

5 years ago
I found that the other bug #846315 is caused by the same problem. That bug was first reported almost a year ago. Is there any chance for the cause of the problem to be fixed this year?

Comment 4

5 years ago
Can you guys still reproduce this?

Comment 5

5 years ago
I can still reproduce the problem in Nightly32.0a1.
https://hg.mozilla.org/mozilla-central/rev/5bbc85136202
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140507030202

Comment 7

5 years ago
Hi
Anyone aware if this is bug fixed in the latest version 32 of firefox? I still see CPU cycles when loading bootstrap.css...in 32 version also.

regards
vijay

Comment 8

5 years ago
Hi,
I tested this today and is still happening on stable Firefox 33.0 and in Beta 34.0, with a lower CPU consumption on Beta on my case (but still a problem). On Windows 7.

But seems solved on Nightly, version 36.0a1 (2014-10-21), an in Aurora 35.0a2 (2014-10-21), so *we may* expect the fix to be on stable version 35.0, right?

May be because of the fix of 846315?
(Reporter)

Comment 9

5 years ago
Hi!

I was creating another responsive website and found another instance of strange Firefox behavior with background images.

I even made a video to demonstrate:

http://www.youtube.com/watch?v=Wv_CLBapKIU

I'm sure that users of single-CPU computers will not like this website (because of the cooler fan noise) due to this Firefox bug.

The wobbling consumes 80-100% of a single CPU.
Whiteboard: [Power]
This is similar to bug 927377, and tn thinks the problem may have been fixed (see bug 927377 comment 5). Alice, can you still reproduce? Thank you.
Flags: needinfo?(alice0775)

Comment 11

4 years ago
WFM on Nightly44.0a3
Flags: needinfo?(alice0775)

Comment 12

4 years ago
oops 44.0a1
Thank you for the update, Alice. I will close this bug accordingly. gnatko, please reopen if you still have problems in current Firefox versions.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.