If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The "Skip" button of the first SIM unlock dialog after reboot cannot be localized

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: timdream, Assigned: tedders1)

Tracking

({l12y, late-l10n, regression})

unspecified
1.3 C2/1.4 S2(17jan)
x86
Mac OS X
l12y, late-l10n, regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

(Whiteboard: [good first bug][systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

STR:

1. Set a SIM PIN lock in Settings app
2. Change the phone language to anything other than English
3. Reboot the phone
4. Unlock the phone lock screen
5. Inspect the SIM Unlock dialog

Expected:

1. "Skip" is localized to label of other locale

Actual:

1. Not localized.

Mark l12y as this is a localizability bug. qawanted to find the earliest reproduced build. 1.3? as we likely have the same bug on 1.3 branch but qa could confirm.

good first bug because this can be fixed simply by adding the string to en-US.properties file.
Let's actually first focus QA Wanted on finding if this reproduces on 1.3 & 1.2.

Comment 2

4 years ago
This issue does NOT reproduce on the Buri 1.2 Build ID: 20131224004001

Gaia   724d36716bcbbc5cee1af18b94cc328c289d0ccc
SourceStamp 931864adcf68
BuildID 20131224004001
Version 26.0

This issue reproduces on the Buri 1.3 Build ID: 20131224004001

Gaia   01e9da49be2cc4bc134eeefc434740d572ec2246
SourceStamp af28fe58e263
BuildID 20131224004001
Version 28.0a2

Also, This issue reproduces on Buri 1.4 Build ID: 20131223040210

Gaia   5c4bb7e9dcdf6f168701508922c232a67cd8ea1f
SourceStamp c0f85061c7d3
BuildID 20131223040210
Version 29.0a1
Keywords: qawanted

Updated

4 years ago
Keywords: regression, regressionwindow-wanted

Comment 3

4 years ago
This issue started to occur on the Buri 1.3 Build ID: 20131210004003

Gaia   3452fbdb5e1bed0cd27cc6173136537a03e8072f
SourceStamp e0c328d99742
BuildID 20131210004003
Version 28.0a2

Last working Buri 1.3 Build ID: 20131209053402

Gaia   1d45d1dc3201059d5c8f2efdeb92c04576d8e161
SourceStamp 9f12a9fab080
BuildID 20131209053402
Version 28.0a1
Keywords: regressionwindow-wanted

Updated

4 years ago
Whiteboard: [good first bug][mentor=timdream][mentor-lang=zh] → [good first bug][mentor=timdream][mentor-lang=zh][FT:System-Platform]
The work does not automatic fall under my team just because I discovered the bug :)
Whiteboard: [good first bug][mentor=timdream][mentor-lang=zh][FT:System-Platform] → [good first bug][mentor=timdream][mentor-lang=zh]
blocking-b2g: 1.3? → 1.3+
Whiteboard: [good first bug][mentor=timdream][mentor-lang=zh] → [good first bug][mentor=timdream][mentor-lang=zh][systemsfe]
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Assignee)

Updated

4 years ago
Assignee: nobody → tclancy
Whiteboard: [good first bug][mentor=timdream][mentor-lang=zh][systemsfe] → [good first bug][systemsfe]
(Assignee)

Comment 5

4 years ago
Created attachment 8358646 [details] [diff] [review]
patch-bug-953041.diff

Adding English, Chinese, and French translations for "skip" button.

Translations were copied from a visually-similar part of the FTU app (gaia/apps/communications/ftu/locales). There's no Arabic translation yet.
Attachment #8358646 - Flags: review?(aus)
(Assignee)

Comment 6

4 years ago
Created attachment 8358664 [details] [review]
Adding English, Chinese, and French translations for "skip" button.

Translations were copied from a visually-similar part of the FTU app (gaia/apps/communications/ftu/locales). There's no Arabic translation yet.
Attachment #8358646 - Attachment is obsolete: true
Attachment #8358646 - Flags: review?(aus)
Attachment #8358664 - Flags: review?(timdream)
Attachment #8358664 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/84829641b0b20b5e7c1a5d0cc43bf6d32d8b4cca
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted 84829641b0b20b5e7c1a5d0cc43bf6d32d8b4cca to:
v1.3: 78836c091bf896ae240786a2e92fa234cfe2dfa2
status-b2g-v1.3: --- → fixed
Keywords: late-l10n
You need to log in before you can comment on or make changes to this bug.