Overflow chevron appearing when no icons inserted from customize palette

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: prittman, Unassigned)

Tracking

(Blocks: 1 bug)

29 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8351395 [details]
Screenshot.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131224030203

Steps to reproduce:

Click on hamburger icon. Click on Customize icon and see customize palette open up.

This has only been happening in the last few days nightlies, from 24 Dec 2013 on back.


Actual results:

After closing customize palette, overflow chevron appears, even though there are no icons to display (inside the overflow field)--see screenshot. This occurs even though there is no need for the overflow chevron.


Expected results:

Since there are no icons available, there should be no overflow chevron appearing on the navigation toolbar.
(Reporter)

Comment 1

4 years ago
I have since tracked it down to an extension (Classic Theme Restorer). 

Anyone: should I mark this as Resolved? Sorry, but I'm not sure what to do now.

Comment 2

4 years ago
What options did you have enabled in the add-on and does changing those make any difference?
Blocks: 872617, 942157
Component: Untriaged → Toolbars and Customization
Flags: needinfo?(prittman)
(Reporter)

Comment 3

4 years ago
One option was to keep the icons at their current size. When the "small icons" option was selected, the problem didn't appear for me. 

What the extension author suggested (which has worked so far) was simply to, in the Customize palette, hit the "Restore Defaults" option, and then arrange my icons on the navigation toolbar again. I did this, as I said, and I haven't seen this problem reappear. 

I didn't get the impression that the extension author, Aris, was going to look for a deeper solution.
Flags: needinfo?(prittman)
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.