Closed Bug 953122 Opened 8 years ago Closed 7 years ago

"Open message in Conversation" is not available for most eMails (new in 24.2.0)

Categories

(Thunderbird :: Mail Window Front End, defect)

24 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: rhod, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

right-click on a message, and "Open message in Conversation" does not show up.


Actual results:

It does show up for some messages (sometimes in the same folder). I think that the situation is worst for new messages.
I never encountered it with the previous versions.
Make sure, you enabled the thread view

EDIT -> Prefernces->Advanced->General, and click on "Config Editor".
In the Config Editor, search for the preference mailnews.thread_pane_column_unthreads. Double-click on it, which should change the value to false.
(In reply to iamjayakumars from comment #1)
> Make sure, you enabled the thread view
> 
> EDIT -> Prefernces->Advanced->General, and click on "Config Editor".
> In the Config Editor, search for the preference
> mailnews.thread_pane_column_unthreads. Double-click on it, which should
> change the value to false.

Well, the thread view is enabled, and the value is false.
The problem is different. All of the new mails (where "new" is different per folder), will not display the "Open message in conversation" when right clicked, while the old mails will.
This is true even within a thread. I see the thread tree, and some of the messages have it, while the new ones, e.g., from today will not let me open the conversation (in a separate tab). Over time, the new messages will "recover" and behave.
I think that this is a new regression, since I never encountered it in the past.

Thanks, Ronen.
try with new profile
(In reply to iamjayakumars from comment #3)
> try with new profile
I didn't get it.
Please try it yourself. Right click on a recently received mail and see if the menu contains and entry for "Open message in conversation". It does not seem to be related to my settings as it does work, except for fresh mail.

Thanks, Ronen.
Hi, Everything works fine for me.. you can see the attachment(screenshot), if you think i'm wrong please provide the screenshot
(In reply to iamjayakumars from comment #5)
> Created attachment 8351677 [details]
> Screen Shot 2013-12-29 at 11.16.13 am copy 2.png
> 
> Hi, Everything works fine for me.. you can see the attachment(screenshot),
> if you think i'm wrong please provide the screenshot


Indeed, it looks good.
I tried mine again. I had a thread with 4 messages. Two opened it, and the latest ones didn't. I closed Thunderbird and restarted, and now all 4 did. It does not always work right away, but over time all the messages recover. Maybe it will reproduce if you leave Thunderbird open for days, and try it on the newest mail.
Attaching a screenshot of two successive messages from linux-kernel.

Thanks, Ronen.
Ronen, Check for fewdays.. still if you have problem. reopen the bug.

I'm closing the bug. according to the comment #7, the issue is solved.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
(In reply to iamjayakumars from comment #8)
> Ronen, Check for fewdays.. still if you have problem. reopen the bug.
> 
> I'm closing the bug. according to the comment #7, the issue is solved.

Just to be clear. In comment #7 I said that your screen shot looks good, but I still have the bug, as I described and attached a screenshot. I believe that you will see it too if you look at a new mail in a big folder with lots of history.
I certainly still see this issue, and it looks like a regression.

Thanks, Ronen.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
A short update:
Since I really use this feature a lot, I downgraded to thunderbird-24.1.0-2.fc20.x86_64, and it didn't solve the problem :-(
I'm experiencing this problem too since ~2 months.
I too tend to remain TB open over several days because of bug 839333 and often shut down my machine to hibernation.
The latest message in my Inbox, where the context menu item still appears, is from 2013-11-24 22:27 CET.
mailnews.thread_pane_column_unthreads=false
I would not wonder, if this problem relates on bug 777491.
In another folder, subfolder of above POP3 Inbox, the latest message, where the context menu item still appears, is from 2013-10-22 14:11 CET.
But there is another correlation: In both, the message after is tagged with "5 later".
But in another account (IMAP), this correlation does not hold. VERY STRANGE !!!

@ Ronen Hod: Please consider to vote on your favourite bugs.
2014-02-06-03-02-05-comm-central-thunderbird-30.0a1.en-US.linux-x86_64

I added a fake POP3 account, created a thread of 3 messages (Send Later), switched threaded view on.  "Open in Conversation" is disabled.  I have tried moving the thread to Inbox, too.
Blocks: 236849
Status: UNCONFIRMED → NEW
Component: Untriaged → Mail Window Front End
Ever confirmed: true
See Also: → 668491
Another short update.
Even if the message is old enough and does let you open the "Open message in Conversation", the conversation will only show the old messages of that thread and ignore the new ones.
In short, it is quite clear that the conversation "database" is updated in a delay of several days, and not in real-time.
As you can probably tell, this is one of the features that I find most useful.
(In reply to [:Aleksej] from comment #14)
> 2014-02-06-03-02-05-comm-central-thunderbird-30.0a1.en-US.linux-x86_64
> 
> I added a fake POP3 account, created a thread of 3 messages (Send Later),
> switched threaded view on.  "Open in Conversation" is disabled.  I have
> tried moving the thread to Inbox, too.

I don't think this should block bug 236849. Conversation "threads" if you want to call them that, are built on gloda.  Issues related to bug 236849 are the result of folder contents and views (including saved searches).
"Open message in conversation" depend on whether gloda is enabled, working and whether the messages in question are indexed.  Install glodaquilla addon to determine the last item. If Gloda id for a message is >16 then the message has been indexed. If not then open in conversation will not be offered. (I tested this on a message in a folder that I have set with glodaquilla to NOT be indexed)

> the conversation "database" is updated in a delay of several days, and not in real-time.

Indexing can be delayed, but shouldn't be days. Normally minutes.

Are you often running on battery power?
Anything else changed in the time period that you updated?
What addons are installed?

(I don't see anything in TB24.2.0 release notes that might obviously cause this problem. Which is in line with comment 10).
Flags: needinfo?(rhod)
(In reply to Wayne Mery (:wsmwk) from comment #17)
> "Open message in conversation" depend on whether gloda is enabled, working
> and whether the messages in question are indexed.  Install glodaquilla addon
> to determine the last item.

Installed, and things started to work right away. To be honest, I didn't check right before the installation, but now it looks good.

 If Gloda id for a message is >16 then the
> message has been indexed. If not then open in conversation will not be
> offered. (I tested this on a message in a folder that I have set with
> glodaquilla to NOT be indexed)
> 
> > the conversation "database" is updated in a delay of several days, and not in real-time.
> 
> Indexing can be delayed, but shouldn't be days. Normally minutes.
> 
> Are you often running on battery power?

I sometimes do. But most of the time I do not run on battery power.

> Anything else changed in the time period that you updated?

I had a SSD disk crash. Switched from Fedora 19 to 20 on non-SSD disk. Kept my .thunderbird (that might be corrupted due to the disk problems, but I do not think so).

> What addons are installed?

If it is still interesting, Plugins or Extensions?

> 
> (I don't see anything in TB24.2.0 release notes that might obviously cause
> this problem. Which is in line with comment 10).

Thanks. It works for me now.
Flags: needinfo?(rhod)
(In reply to Ronen Hod from comment #18)
> (In reply to Wayne Mery (:wsmwk) from comment #17)
> > "Open message in conversation" depend on whether gloda is enabled, working
> > and whether the messages in question are indexed.  Install glodaquilla addon
> > to determine the last item.
> 
> Installed, and things started to work right away. To be honest, I didn't
> check right before the installation, but now it looks good.

Thanks.

>  If Gloda id for a message is >16 then the
> > message has been indexed. If not then open in conversation will not be
> > offered. (I tested this on a message in a folder that I have set with
> > glodaquilla to NOT be indexed)
> > 
> > > the conversation "database" is updated in a delay of several days, and not in real-time.
> > 
> > Indexing can be delayed, but shouldn't be days. Normally minutes.
> > 
> > Are you often running on battery power?
> 
> I sometimes do. But most of the time I do not run on battery power.

I've never tested it myself, but I recall reading that indexing is suspended while on battery power.


> > Anything else changed in the time period that you updated?
> 
> I had a SSD disk crash. Switched from Fedora 19 to 20 on non-SSD disk. Kept
> my .thunderbird (that might be corrupted due to the disk problems, but I do
> not think so).
> 
> > What addons are installed?
> 
> If it is still interesting, Plugins or Extensions?

extensions
Status: NEW → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.