Closed Bug 953191 Opened 7 years ago Closed 6 years ago

Often get glitches in audio output when using Web Audio API

Categories

(Core :: Web Audio, defect, P2)

26 Branch
x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 848954

People

(Reporter: fluffy, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

I put and example HTML pages that generates a short (32 ms long) burst of 1100 Hz tone. You can find this example at https://gist.github.com/fluffy/8136414 When I run it with FF 26.0 on osx, I often get glitches in the output done that sound static like. I have tried on a few macs with a few different sound cards at it is the same problem on all of them. 


Actual results:

I ran the code at https://gist.github.com/fluffy/8136414 and captured the output on a scope and it looks like 

http://www.flickr.com/photos/cullenfluffyjennings/11568178575/

You can see that about ever 10 ms, the output has a few ms of all zero when it should not. 



Expected results:

Here is what the wavform should look like. This was captured by running the same code but using Chrome instead of FF. In Chrome it looks like 

http://www.flickr.com/photos/cullenfluffyjennings/11568212444
Component: Untriaged → Web Audio
Product: Firefox → Core
Bogdan, Anthony -- Can one of you try to reproduce this with Nightly?  This may affects games.  (Cullen may have found a performance problem with ramping values.)
Flags: needinfo?(bogdan.maris)
Flags: needinfo?(anthony.s.hughes)
Keywords: qawanted
Priority: -- → P2
I ran the code from comment 0 but was unable to capture the output. Is there an online software that I can use in order to see the output?
I browsed the web for something to use and I found this: http://www.dxzone.com/dx22936/digital-oscilloscope-and-analyzer-software.html
I don`t quite know if this is of any help but I thought I should mention this.
Flags: needinfo?(bogdan.maris) → needinfo?(fluffy)
Karl -- See Comment 2.  Can you help advise Bogdan on what to use?  Thanks.
Flags: needinfo?(karlt)
Hi - I'll think about this and see what we can do if you don't have a scope. I have not used any of the purely software scopes but I know a bunch exist for ipad and other things. I think that if you take that page I put in the bug and just load it 10 times in a row, some of the time you will hear a really static crinkly noise that sounds clearly wrong so you can probably duplicate it without even looking at the scope output. Hope that helps Cullen
Attached file fluffy.html
I can definitely hear a faint "pop" when loading the test file but not every time. I tested this in Firefox 29.0a1 on Ubuntu 13.10 64-bit. I've attached the test file here for posterity.
Flags: needinfo?(anthony.s.hughes)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
I am also able to reproduce this "pop" in Firefox 25 so I don't think this is a regression. Clearing needinfo flags since I think this satisfies the original request. Please let me know if there's something more I can do to help.
Flags: needinfo?(karlt)
Flags: needinfo?(fluffy)
I suspect this is one of things that bug 848954 should address.

If the silence repeats at 12 ms intervals regularly, or the problem continues to be frequent on an older AudioContext, then there may be something else here.
Depends on: 848954
Still seems to happen with 32.0 but does not seem to happen with 34.0a2
Thanks.  That seems to confirm bug 848954 as the cause.
Status: NEW → RESOLVED
Closed: 6 years ago
No longer depends on: 848954
Resolution: --- → DUPLICATE
Duplicate of bug: 848954
You need to log in before you can comment on or make changes to this bug.