A project name should precede terms.Bugzilla in many places

RESOLVED DUPLICATE of bug 770073

Status

()

RESOLVED DUPLICATE of bug 770073
5 years ago
5 years ago

People

(Reporter: connor.behan, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130522 Firefox/20.0 (Nightly/Aurora)
Build ID: 20130523170432

Steps to reproduce:

Step 1: Become interested in free software.
Step 2: Find a bug in GNOME.
Step 3: Get an account on bugzilla.gnome.org to report it.
Step 4: Find a bug in Xorg.
Step 5: Go to bugs.freedesktop.org where it says you "need a Bugzilla account".
Step 6: Try to login with your bugzilla.gnome.org account.
Step 7: Rage about it not working. "I already have a Bugzilla account! Rawr!"


Actual results:

I am of course referring to template/en/default/account/auth/login.html.tmpl. This says "If you don't have a Bugzilla account, you can create a new account" but there is no such thing as "a Bugzilla account in general". This may sound daft but having this on every Bugzilla could give users the impression that there is some "one and only Bugzilla" especially if they are new to free software.


Expected results:

I'm not sure how to solve it. The only way for the software to "know" the project name is the PROJECT environment variable which most people don't use. A suggestion in bug 553553 is to have terms.Bugzilla product. Then we count make the default value of terms.Bugzilla say "MyProject Bugzilla" which is ugly enough that it will convince most site maintainers to pick a sensible value right away.

Is this acceptable? If not I will go with my backup plan of reporting bugs on every Bugzilla I know of (including this one) telling the webmasters to brand the name like they are supposed to.

Comment 1

5 years ago
PROJECT is something totally different and shouldn't be used for this purpose. Having a separate variable has already been proposed in bug 553553, and bug 770073 has been filed to implement this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770073
You need to log in before you can comment on or make changes to this bug.